Can't upload images to Wordpress after transfer to VPS


#1

Hi guys,

I recently had my Wordpress blog transferred to a VPS from a shared hosting and I stumbled into a problem.

All else seem to work perfectly but I'm having problem with uploading images.

Formerly it seems like my site is not running but my friend managed to transfer it over to my new VPS running on Nginx.

My question is how can I enable image uploading? It says this error.

"The uploaded file could not be moved to wp-content/uploads/2013/09."

The Theme and Plugin editor are also untouchable at this time.

Can you advice me on how can I fix it?

My VPS info:

  • Debian 6 64bit
  • 1GB RAM

Thank you very much!


#2

You should try fixing the permissions of folders on your server Try running these commands, it should do the job

# Give Ownership To www-data  
chown -R www-data:www-data /var/www  

# Correct Directory Permissions  
find /var/www -type d -exec chmod 0755 {} \;  
# Correct Files Permissions  
find /var/www -type f -exec chmod 0644 {} \;  

#3

Hello there Gagan!

I've tried your suggestion and it worked! Thanks so much mate! :-)


#4

Welcome :)


#5

Thank you! This worked for me too!


#6