Can't seem to fix nginx dependency issue


#1

Hi.

I’ve seem to have messed up my ee installation. Now, I can’t get ee to do anything (create sites, install stack, etc). From the error below, it seems I have a dependency issue with nginx’s packages. I’ve tried purging nginx and reinstalling but I can’t seem to solve the issue.

I have Phusion Passenger installed on top of ee’s stack. Not sure if that can cause issue with the packages.

nginx as the web server is working fine as it is now. All the sites I’ve created prior to the current issue are working fine. The only issue is when I do anything with ee.

Any ideas?

2015-07-16 00:51:55,833 (INFO) ee : Installing packages, please wait...
Reading package lists...
Building dependency tree...
Reading state information...
nginx-common is already the newest version.
nginx-common set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nginx-custom : Depends: nginx-common (= 1.8.0-8ppa) but 1:1.8.0-8.5.0.14~trusty1 is to be installed
E: Unable to correct problems, you have held broken packages.
2015-07-16 00:51:56,487 (INFO) ee : Oops Something went wrong!!
2015-07-16 00:51:56,488 (ERROR) ee : Check logs for reason `tail /var/log/ee/ee.log` & Try Again!!!

#2

@weyhan

can you give me list of nginx packages which you have currently installed?

Please give me output of following command

dpkg -l | grep nginx


#4

@harshadyeola

Here is the output you’ve requested:

$ dpkg -l | grep nginx
ii  nginx-common                        1:1.8.0-8.5.0.14~trusty1             all          small, powerful, scalable web/proxy server - common files
ii  nginx-extras                        1:1.8.0-8.5.0.14~trusty1             i386         nginx web/proxy server (extended version)
ii  nginx-full                          1:1.8.0-8.5.0.14~trusty1             all          small, powerful, scalable web/proxy server

#5

@weyhan

Hi, have you tried running this: sudo tail /var/log/ee/ee.log

This should show where the conflict is. In my case it is an unmet dependency of phpapi-20121212.

Is you output the same?

:slight_smile:


#6

The log snippet is in my original post. The issue for me is nginx-common. Nothing to do with phpaip.


#8

dome can help me with this issue please 2016-03-08 16:30:11,793 (DEBUG) ee : logging initialized for ‘ee’ using LoggingLogHandler 2016-03-08 16:30:12,016 (DEBUG) ee : [’/usr/local/bin/ee’, ‘stack’, ‘start’, ‘–nginx’] 2016-03-08 16:30:12,016 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.ba se.EEBaseController object at 0x7f70e38069e8> 2016-03-08 16:30:12,017 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack. EEStackController object at 0x7f70e3806c88> 2016-03-08 16:30:12,018 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.stack_ services.EEStackStatusController object at 0x7f70e3815550> 2016-03-08 16:30:12,021 (INFO) ee : Initializing EasyEngine Database 2016-03-08 16:30:13,583 (INFO) ee : Nginx is not installed


#9

well forum is so quiet some body can refer me for help thanks


#10