Can't PHP start/max/min children for some reason

Hi all,

We are having this kind odd issue with php7 on easy engine 3.7.5 with fastcgi: we edit the www.conf file to change these but realoding/restarting the service, even rebooting the droplet in Digital Ocean does not change a thing… it comes back with 0 starting children and just spawns more as the traffic starts to come in. We mainly want to increase the start servers so it can handle spikes in traffic better…

pm = ondemand
pm.max_children = 100
pm.start_servers = 50
pm.min_spare_servers = 40
pm.max_spare_servers = 60

Anyone ever experienced this or should I change some other files to the changes to apply?

ee v3 hasn’t been supported for a long time now - even critical security fixes ended January last year! :worried:

So it would be wise to either upgrade to v4 or migrate over to WordOps which was a fork of v3 that has improved on it a lot and is still supported. More info on all that here.

1 Like

Check if the file you are editing.
How to find out which config is working?

sudo cat /etc/nginx/conf.d/upstream.conf

upstream php7 {
server unix:/var/run/php7.0-fpm.sock;
}

Possible config options:
/etc/php/7.0/fpm/pool.d/www.conf
/etc/php/7.1/fpm/pool.d/www.conf
/etc/php/7.2/fpm/pool.d/www.conf
/etc/php/7.3/fpm/pool.d/www.conf

I use v3 on two servers. Everything is working. Everything suits me.

It may work but it is a security risk :slight_smile:. I stayed with v3 for a long time too - but WordOps works exactly the same way (because it is v3 with extra development), and is pretty easy to move over to.