Can't install WP anymore

Switching the package to another country/language does work as a temporary solution. The correct spacing of the text in the ~/.wp-cli/config.yml file is extremely important or it will not work. It should also be noted that this file does not exist on a default EE install. You will have to create it.

The US package is corrupt in some way so unless it gets rebuilt and reuploaded the US version will not work until the next release of wp from what I can tell.

Thanks !

What are the commands to do this in putty? I didn’t find the config.yml so It would be perfect if you can help with command lines :wink:

Thank you!

CONFIGYML="/root/.wp-cli/config.yml"
echo "core download:" > $CONFIGYML
echo "  locale: pt_BR" >> $CONFIGYML
1 Like

Thank you!

Should I just run “ee site create test.com --wpfc” after these lines?

It’s not working if I just run this after adding this file.

Thank you!

I’m guessing it’s got something to do with the security update wordpress released yesterday.

From what i’ve gathered through looking at the history of these types of errors I am guessing that it has to do with a corrupt tar.gz file that is not able to be decompressed. The english/US version of the file would have to be replaced by the wp-cli people I believe. Someone correct me if I am wrong in thinking they would be the ones to contact.

zual, run each of those lines separately in the terminal. You may have to sudo them if you are not logged in as root though. Then you should be able to run normal ee create commands for wp installations. The resulting installation will be in the portuguese language but you can login and go to general settings and change the language to whatever you need.

You can do this as temporary.

wp core download --version=4.8

Then go to /root/.wp-cli/cache/core cp -pa wordpress-4.8-en_US.tar.gz wordpress-4.8.2-en_US.tar.gz

then install with ee ee site create site.com --wpfc (example)

Bests for all

1 Like

Thank you it works perfectly ! :wink:

Its been 24hours now since this problem started.

Any chance we could hear back from someone at RTCamp soon?

1 Like

@Marcos_Carvalho, thank you. I can now install wp using ee site create command.

I just would like to note that when I run the wp core download --version=4.8, it downloaded all wp files. It was not zipped. But fortunately, there was already a 4.8 version downloaded to my ‘/root/.wp-cli/cache/core’ directory.

So all I had to do at this point is run the command inside my ‘/root/.wp-cli/cache/core’ directory: cp -pa wordpress-4.8-en_US.tar.gz wordpress-4.8.2-en_US.tar.gz Then everything went smoothly. Hope this clarify things for other people who are experiencing the same problem.

Same problem here … Please help Easyengine Expert from comapany…

Running pre-update checks, please wait… Setting up NGINX configuration [Done] Setting up webroot [Done] Downloading WordPress [Fail] Oops Something went wrong !! Calling cleanup actions … ‘ee_mysql_grant_host’

Exact same here…

This is NOT an EE’s issue. There’s nothing someone at RTCamp can do to solve a corrupted package at WordPress repository.

Until the kind people at Automattic create a new, functional, .tar.gz file, we have to deal with the issue with this workaround.

I suggested the pt_BR package because it is what suits my needs. But I remember en_UK also works. en_UK is not that different from en_US, and one always can change locale after WP is installed.

Please, don’t expect solutions from where it can’t come from. :slight_smile: It might cause way too frustration.

1 Like

so where exactly is this line?

I think you need to check here how you create a config.yml file if you want to do that.

You can also get a nightly via Phar too. They have done a dirty fix in wp-cli.

And last, follow up this thread where you can more info about the bug.

So please close this ticket coz EE have no solution of this …

Same issue this morning, this worked perfectly. Thank you!

sudo ee stack remove --wpcli

taken from wp-cli.org/#installing

curl -O https://raw.githubusercontent.com/wp-cli/builds/gh-pages/phar/wp-cli.phar chmod +x wp-cli.phar sudo mv wp-cli.phar /usr/local/bin/wp wp cli update --nightly

end: Success: Updated WP-CLI to the latest nightly release.

sudo ee site create site.com --wp

Running pre-update checks, please wait… Setting up NGINX configuration [Done] Setting up webroot [Done] Downloading WordPress [Done] Setting up database [Done] Installing plugin nginx-helper, please wait… Reload : nginx [OK]

Good job.

3 Likes

Borrowing from @portofacil suggestion. Changing the locale feels clunky. Instead configure wp-cli to install WP 4.8, the pervious WP version.

steps

create a wp-cli config file that will override the wp-cli defaults.

touch ~/.wp-cli/config.yml

now open the file. (Nano is my preferred text editor)

nano ~/.wp-cli/config.yml

paste the following and save.

core download:
  version: 4.8
  • yaml is whitespace sensitive… That means indention matter and I prefer spaces. Following my example, make sure there is no space in front of 'core" and two spaces in front of version".

Now run your normal EE commands for WP installation. After it completes simply login and WordPress will notify you an upgrade is available.

Click the link and WP will upgrade without incident.

Eventually this issue will be resolved. When that happens simply delete the config file you created and you will be all set.

8 Likes

Thanks @jwogrady, to make the fix easier, I have posted it on my git. This way, it require only to use a single command to fix this issue :

wget -O ~/.wp-cli/config.yml https://git.virtubox.net/virtubox/debian-config/raw/master/config.yml
1 Like