Can't install WP anymore

Exact same here…

This is NOT an EE’s issue. There’s nothing someone at RTCamp can do to solve a corrupted package at WordPress repository.

Until the kind people at Automattic create a new, functional, .tar.gz file, we have to deal with the issue with this workaround.

I suggested the pt_BR package because it is what suits my needs. But I remember en_UK also works. en_UK is not that different from en_US, and one always can change locale after WP is installed.

Please, don’t expect solutions from where it can’t come from. :slight_smile: It might cause way too frustration.

1 Like

so where exactly is this line?

I think you need to check here how you create a config.yml file if you want to do that.

You can also get a nightly via Phar too. They have done a dirty fix in wp-cli.

And last, follow up this thread where you can more info about the bug.

So please close this ticket coz EE have no solution of this …

Same issue this morning, this worked perfectly. Thank you!

sudo ee stack remove --wpcli

taken from

curl -O chmod +x wp-cli.phar sudo mv wp-cli.phar /usr/local/bin/wp wp cli update --nightly

end: Success: Updated WP-CLI to the latest nightly release.

sudo ee site create --wp

Running pre-update checks, please wait… Setting up NGINX configuration [Done] Setting up webroot [Done] Downloading WordPress [Done] Setting up database [Done] Installing plugin nginx-helper, please wait… Reload : nginx [OK]

Good job.


Borrowing from @portofacil suggestion. Changing the locale feels clunky. Instead configure wp-cli to install WP 4.8, the pervious WP version.


create a wp-cli config file that will override the wp-cli defaults.

touch ~/.wp-cli/config.yml

now open the file. (Nano is my preferred text editor)

nano ~/.wp-cli/config.yml

paste the following and save.

core download:
  version: 4.8
  • yaml is whitespace sensitive… That means indention matter and I prefer spaces. Following my example, make sure there is no space in front of 'core" and two spaces in front of version".

Now run your normal EE commands for WP installation. After it completes simply login and WordPress will notify you an upgrade is available.

Click the link and WP will upgrade without incident.

Eventually this issue will be resolved. When that happens simply delete the config file you created and you will be all set.


Thanks @jwogrady, to make the fix easier, I have posted it on my git. This way, it require only to use a single command to fix this issue :

wget -O ~/.wp-cli/config.yml
1 Like

@virtubox, updating WP-Cli to the nightly version should be enough. They did a dirty fix for this issue.

Changing locale using the YAML configuration file is a little bit dangerous, because when a new version of WP is released they take some time to provide the non-en_US archives.

I haven’t include the code to change locale, only the WP version to 4.8

Very nice.

Anyways, one shouldn’t forget to wp core update just after installation, in order to keep their blogs running on latest version.

1 Like

Thank you. This works perfectly here.

thank you for your solution. Perfect for handle this error

hello @jwogrady and @virtubox that’s a good solution.

i searched at there is no Translation Teams/Locales for en_US !!

you no need to remove the wp-cli, just update to latest version. your solution is quite good if the locale is different. this issue is only for en_US locale.

The wp cli version on my Ubuntu 16.04 box was really old. Can anyone confirm jumping up to v1.3.0 still works with easyengine? I can still change existing sites, just not create new WP 4.8.2 sites.

$ wp cli version
WP-CLI 0.24.1

#wp cli update --allow-root
You have version 0.24.1. Would you like to update to 1.3.0? [y/n]
1 Like

Yes, it works fine.

Enviado do meu iPhone

perfectly wooorkkssss !! thanksssss

This one works perfectly to me.

sudo ee stack remove --wpcli
curl -O
chmod +x wp-cli.phar
sudo mv wp-cli.phar /usr/bin/wp
wp cli update --nightly
1 Like

Thanks, worked for me,