Can't install on Debian 9


#1

Get’s the following message: EasyEngine (ee) only support Ubuntu 12.04/14.04 and Debian 7.x/8.x

I guess that’s just a simple check, but is there any good reason for it?

EDIT: seems like Linode D9 installation is not ready for ee yet - at least one thing is missing, some python installation EE - try to make it happen in the next version!


#2

If you can remove the check done during the ee installation about the debian release, you may have issues with packages and repository. I will wait for the next release to migrate to debian 9. If debian is a stable distribution, I prefer to wait few months to make sure there are no issues on production.


#3

Thanks

That’s what happened. I wanted to start and try the new 9, but perhaps I it’s better to wait


#4

Yes, I have already EE with the first release with Debian 8 Jessie, and there was some issues.

Here the server packages list updated on stretch (with the previous in brackets) :

Global : Linux 4.9 (3.16) GCC 4.6 (4.4) systemd 232 (215) Perl 5.34 (5.20) htop 2.0 (1.0) nano 2.7 (2.2) vim 8.0 (7.4) fail2ban 0.9 (0.8) Python 3.5 (3.4) Python 2.7.13 (2.7.9) OpenSSL 1.1.0 (1.0.1) OpenSSH 7.4 (6.7) GnuPG 2.1 (1.4) OpenJDK 8 (7) LibreOffice 5.2 (4.3)

Web :

PHP 7.0 (5.6) Nginx 1.10 (1.6) Apache 2.4.25 (2.4.10) MariaDB 10.1 (MySQL 5.5) PostgreSQL 9.6 (9.4) Redis 3.2 (2.8)


#5