Can't create domain with www prefix. "too many values to unpack (expected 2)"


#1

Trying to create a site using ee site create www.domain.com --wpfc but it will not work. Gives me

“too many values to unpack (expected 2)”

and then does nothing. When I try to create the site without the www, it works just fine.

Client wants www. So I have to have it. What could be the cause of this? Is there an easy way to solve it? 4 other websites on this VPS (Digital Ocean, Ubuntu 14.04) have worked flawlessly thus far… but I cannot create a site with www in front of it.

Other subdomains, no problem… but not www.


#2

@oldschool101

Which version of EasyEngine you are using?

It does not seem to be problem with current EasyEngine version.


#3

Latest version as far as I can tell. I created this droplet a week ago, and ran your standard process for installation at that time.

Is there some sort of command I can run to get a lot that will help you? Whatever I have to do…


#4

I updated using “wget -qO ee rt.cx/ee && sudo bash ee” as I found ee update doesn’t work anymore.

Now it appears to work, however, it creates this site WITHOUT the www. in front of it.

So… the command entered:

sudo ee site create www.domain.com --wpfc

The output from the server is then as follows (actual data redacted and replaced by things CAPITALIZED:

xi@xiagency:~$ sudo ee site create www.DOMAIN.com --wpfc
Setting up NGINX configuration 	[Done]
Setting up webroot 		[Done]
Downloading Wordpress 		[Done]
Setting up database		[Done]
Installing plugin nginx-helper
Installing plugin w3-total-cache
Reload : nginx     [OK]
WordPress admin user : USERNAME
WordPress admin user password : PASSWORD
Configure nginx-helper:	http://DOMAIN.com/wp-admin/options-general.php?page=nginx
Configure W3TC:		http://DOMAIN.com/wp-admin/admin.php?page=w3tc_general
Page Cache:		Disable
Database Cache:		Memcached
Object Cache:		Memcached
Browser Cache:		Disable
Successfully created site http://DOMAIN.com

So, the question here is then this: How do I make this site appear as www.domain.com, rather than just domain.com?

Thank you for your time. Very much appreciated.


#5

Wanted to include a photo of the output I’m getting on this now. When I go to delete the site using www, this confirms that the site doesn’t exist, but the non www one does. There is a small bit in there also where I edited the default Wordpress username and password in ee.conf, which is probably irrelevant here.


#6

Sorry about all the updates, but this will be the final one… because the issue is resolved.

While the interface still says that it created the site without the www, and the actual directory for which the files are found is the domain without the www… the site itself, is found at www. Very odd, but it appears to be fine, despite the server telling me everywhere that it isn’t with www.

Thank you for at least responding. Your time is valuable, I hope I didn’t waste it.


#7

EE seems to create vhost / listener for both the naked domain and www subdomain by default for any domain you create if prefixed with www. However the /etc/nginx/sites-available and /etc/nginx/sites-enabled as well as echos in the interface will not show www


#8

Hi @oldschool101

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#9