Can't create a wordpress site


#1

Hi I’m new to easyengine. I tried to set up a wordpress site on my vps with ubuntu 14.04 so;

sudo ee site create mysite.com --wp

but it dosnt work for me:

Setting up NGINX configuration     [Done]
Setting up webroot         [Done]
Downloading Wordpress         [Done]
Setting up database        Oops Something went wrong !!
Calling cleanup actions ...
'ee_mysql_grant_host'

I read about this problem in this forum but really there was nothing to fix this. All services runs fine but idk what is it thank u for helping


#2

hello @Yaser

Could you please provide output of tail -n50 /var/log/ee/ee.log .

Also please check if you could login to mysql using

mysql

from command line .


#3

Hi, thank u

root@vps10460:~# tail -n50 /var/log/ee/ee.log
2015-11-17 01:17:04,050 (DEBUG) ee : dropping user `None`
2015-11-17 01:17:04,058 (ERROR) ee : Error occured while deleting database
2015-11-17 01:17:04,218 (INFO) ee : Deleted Database successfully.
2015-11-17 01:17:05,192 (INFO) ee : Deleting Webroot, /var/www/technogeek.ir
2015-11-17 01:17:05,192 (DEBUG) ee : Removing /var/www/technogeek.ir
2015-11-17 01:17:05,192 (DEBUG) ee : Removing /var/www/technogeek.ir
2015-11-17 01:17:05,382 (INFO) ee : Deleted webroot successfully
2015-11-17 01:17:05,382 (DEBUG) ee : Removing Nginx configuration
2015-11-17 01:17:05,382 (DEBUG) ee : Removing /etc/nginx/sites-enabled/technogeek.ir
2015-11-17 01:17:05,383 (DEBUG) ee : Removing /etc/nginx/sites-available/technogeek.ir
2015-11-17 01:17:05,383 (INFO) ee : Reload : nginx     
2015-11-17 01:17:05,484 (INFO) ee : [OK]
2015-11-17 01:17:05,497 (DEBUG) ee : EEGit: git commit at /etc/nginx
2015-11-17 01:17:06,052 (INFO) ee : Deleted site technogeek.ir
2015-11-17 01:17:10,553 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler
2015-11-17 01:17:10,919 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'create', 'technogeek.ir', '--w3tc']
2015-11-17 01:17:10,919 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f688238df98>
2015-11-17 01:17:10,921 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7f68823991d0>
2015-11-17 01:17:10,922 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteCreateController object at 0x7f6882399a90>
2015-11-17 01:17:10,925 (INFO) ee : Initializing EasyEngine Database
2015-11-17 01:17:10,930 (DEBUG) ee : Setting apt_packages variable for Nginx
2015-11-17 01:17:12,218 (DEBUG) ee : Finding string SCRIPT_FILENAME to file /etc/nginx/fastcgi_params
2015-11-17 01:17:12,218 (DEBUG) ee : Setting apt_packages variable for PHP
2015-11-17 01:17:13,213 (DEBUG) ee : Setting apt_packages variable for MySQL
2015-11-17 01:17:13,213 (DEBUG) ee : Running command: mysqladmin ping
2015-11-17 01:17:13,265 (DEBUG) ee : Setting apt_packages variable for Postfix
2015-11-17 01:17:14,218 (DEBUG) ee : Setting packages variable for WP-CLI
2015-11-17 01:17:14,218 (DEBUG) ee : Running command: which wp
2015-11-17 01:17:14,230 (INFO) ee : Running pre-update checks, please wait...
2015-11-17 01:17:14,230 (DEBUG) ee : checking NGINX configuration ...
2015-11-17 01:17:14,295 (INFO) ee : Setting up NGINX configuration     
2015-11-17 01:17:14,298 (DEBUG) ee : loading template file /usr/lib/ee/templates/virtualconf.mustache
2015-11-17 01:17:14,363 (DEBUG) ee : Checking generated nginx conf, please wait...
2015-11-17 01:17:14,395 (INFO) ee : [Done]
2015-11-17 01:17:14,395 (DEBUG) ee : Creating Symbolic link, Source:/etc/nginx/sites-available/technogeek.ir, Dest:/etc/nginx/sites-enabled/technogeek.ir
2015-11-17 01:17:14,395 (INFO) ee : Setting up webroot         
2015-11-17 01:17:14,396 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/technogeek.ir.access.log, Dest:/var/www/technogeek.ir/logs/access.log
2015-11-17 01:17:14,396 (DEBUG) ee : Creating Symbolic link, Source:/var/log/nginx/technogeek.ir.error.log, Dest:/var/www/technogeek.ir/logs/error.log
2015-11-17 01:17:14,396 (INFO) ee : [Done]
2015-11-17 01:17:14,529 (INFO) ee : Downloading Wordpress         
2015-11-17 01:17:14,529 (DEBUG) ee : Changing directory to /var/www/technogeek.ir/htdocs/
2015-11-17 01:17:14,530 (DEBUG) ee : Running command: wp --allow-root core download
2015-11-17 01:17:15,679 (INFO) ee : [Done]
2015-11-17 01:17:15,679 (INFO) ee : Setting up database        
2015-11-17 01:17:15,680 (DEBUG) ee : Creating database technogeek_ir
2015-11-17 01:17:15,688 (DEBUG) ee : [Error]Setting up database: '54'
2015-11-17 01:17:15,688 (DEBUG) ee : 
2015-11-17 01:17:15,688 (DEBUG) ee : 'MySQL Connectivity problem occured'
2015-11-17 01:17:15,688 (INFO) ee : Oops Something went wrong !!
2015-11-17 01:17:15,688 (INFO) ee : Calling cleanup actions ...

yes, first I tried to create mysql db and user manually then I fuond that I cant access wordpress cuz there is no nginx conf file for my added site


#4

hello @Yaser

There is ‘MySQL Connectivity problem occured’ .

Could you check if credentials at

cat /etc/mysql/conf.d/my.cnf

are correct .


#5

Thank u for answer

there was a user name:root and a password I tried:

root@vps10460:~# mysql -u root -p
Enter password: 
Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 94
Server version: 10.1.8-MariaDB-1~trusty-log mariadb.org binary distribution

Copyright (c) 2000, 2015, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [(none)]> 

I can create DB and DBuser, its works fine


#6

Could you please check if following database already exist :

technogeek_ir


#7

Really thank u I just test everything, then I reinstall OS, now problem solved, idk what was that but I think everyone must install ee on a fresh OS. ee is a great job, like it


#8

I am having the same problem, not really keen to re-install the OS again. was working great for long time and now same error as above.

I have checked my DB and the Database is not being created. Have no problems accessing MySQL via CMD or through PHPmyAdmin


#9

Check if the password stored in /etc/mysql/my.cnf (or /root/my.cnf if it’s an old install) matches the actual password you use to manually access MariaDB, according to the information you shared.


#10

Happy I found this it solved my problem! Thanks


#11