Can't connect to database on MySQL Workbench nor Sequel Pro on Ubuntu 16.04 (Digitalocean)


#1

Hey there rtCommmunity!

This is my third attempt on creating a fresh new droplet on Digitalocean just to see if I’m able to connect to the mysql database using the MySQL Workbench app or Sequel Pro apps on Mac. The result: a total disappointment in the end.

Right after the droplet is ready, the overall EE installation and the site creation using ee site create mydomain.com —wpfc is smooth and I end up with a great working WordPress install under Nginx + fastcgi-cache, so far so good.

However, I’m facing a nightmare trying to connect to the mysql database using MySQL Workbench or Sequel Pro apps on Mac, no matter what I do, I just can’t get it to work!

I just can’t stand with EE default Mysql root password, so right after creating the site I’ve successfully changed the password the Mysql root password on Terminal as also under /etc/mysql/conf.d/my.cnf

Right after that I then stop and restart all the EE stack services with the commands ee stack reload and ee stack restart.

After restarting the services I’m perfectly able to login to Mysql under the terminal with my new Mysql root password, so no issues with the login droplet and Mysql login credentials.

Not sure what is causing this issue, all other droplets I have with manually installed LEMP stacks are able to connect to Mysql database, with exception of those managed with EE.

  • I keep getting SSH Tunnel timeout error as follows:

Could not connect the SSH Tunnel

Authentication error, unhandled exception caught in tunnel manager, please refer to logs for details

Failed to Connect to MySQL at 127.0.0.1:3306 through SSH tunnel at 192.222.222.122(droplet ip) with user root

Tunnel connection cancelled

I’d really appreciate any help regarding this issue. Thanks for your time!


#2

@monecchi Please check if the mysql-root-user is enabled for remote hosts access. You need to check the mysql.user table

SELECT user, host FROM mysql.user;

If not then you can enable remote host access for the mysql-root-user and then check again.

CREATE USER 'DBuser'@'%' IDENTIFIED BY 'DBpassword';

GRANT ALL PRIVILEGES ON *.* TO 'DBuser'@'%' WITH GRANT OPTION;


#3

@radhakrishnanmu Thanks for your input. The root user has remote access enabled as also the db user I created myself. The issue persisted on a fresh ubuntu 16.04 install created on Digitalocean.

After creating a new server with Ubuntu 14.04 and reinstalling EE it finally worked!

It seems to be something related to the Ubuntu 16.04 + EE. I also followed instructions on this EE tutorial https://easyengine.io/tutorials/mysql/remote-access/ - After all, I’m not not sure if that’s what solved the issue, but as long as it works I’m fine with Ubuntu 14.04 + EE.


#4