Can't change WordPress Address (URL) & Site Address (URL)

Hi,

I was getting insecure content warnings and noticed my logo is http:// and not https://. Upon checking, all my images in my media library point to http://, though they do redirect to their secure version. I then noticed that in Settings > General, the site address and wordpress address were both set to the http:// version. However, I cant update these to https://, when I click save changes nothing happens and they revert back to http://

Any ideas?

I managed to stumble upon a solution which seems to have worked, by using WP-CLI.

Enter WP-CLI with:
ee shell example.com

Then:

wp option update home ‘https://example.com
wp option update siteurl ‘https://example.com