Can't access Easy Engine Admin tools / 22222?


#1

Hello everybody!

I’m really new to Easy Engine and Virtual hosting in general so please excuse my n00bness… xD
My Problem I cant access Easy Engine admin…at all!?

What happends?
It dont ask me for login. Just displays like the site dont exist… Frustration…

I have tried this:
ee stack admin remove
ee stack admin install

Tried typing direct Ip address:
https://139.xxx.xxx.xx:22222/

Sites enabled - Found it here
Sites available - Found it here
var/www - Found it here

Still dont work…!??

Clues to my Issue
But when i type following command: ee site enable 22222
I get a red message saying: site 22222 does not exist

Status on my domain:
root@localhost:~# HTTP/1.1 302 Moved Temporarily -bash: HTTP/1.1: No such file or directory root@localhost:~# Server: nginx Date: Mon, 26 Oct 2015 11:45:52 GMT Server:: command not found Content-Type: text/html root@localhost:~# Date: Mon, 26 Oct 2015 11:45:52 GMT Content-Length: 154 Connection: close Location: https://139.xxx.xxx.xx:22222/ X-Powered-By: EasyEngine 3.3.10 Date:: command not found root@localhost:~# Content-Type: text/html

HTTP/1.1 401 Unauthorized Server: nginx Date: Mon, 26 Oct 2015 11:45:52 GMT Content-Type: text/html Content-Length: 188 Connection: keep-alive WWW-Authenticate: Basic realm=“Restricted Area”

Btw im working with Linode.
I really appriate any help out there.
Thanks in advance.

/Best regards
Clueless n00b Seb


#2

i think im having a similar issue…

any luck with this?


#3

Yo Mahir!

Nah man Never solved it. I actually gave up on this totally months ago… But I still manage to get what I need to do without it… Would be awesome however to see it working. Dont even know how it looks like. Let me know if you get it to work.


#4

it would be useful if you can post a screenshot with what you get when you try to access :22222


#5

Just wondering… do you have a firewall setup? I was encountering the same issues, allowing port 22222 through was the solution.

You can check the status of UFW with this command:
sudo ufw status verbose

If UFW is active, the output will say that it’s active, and it will list any rules that are set. If you don’t see 22222 listed, you can use this command to allow connections on that port:
sudo ufw allow 22222

You can also specify a specific IP address (if static) that is allowed to connect to by adding “to any port” followed by the port number.
sudo ufw allow from 12.34.56.78 to any port 22222

Reload firewall after making changes:
sudo ufw reload

Hope that helps!


#6

Yo Jentan! IT SURE DID!:grin: You solution worked like a charm… Thank you so much! :joy: Whoa! Gotta say its like a whole new world with easy engine now when the admin tools actually works haha. Amazing. Really kind of you. Thanks again!!!


#7

Awesome, glad to hear that! The pleasure is all mine! :wink:


#8

You can reset to correct upper lower case username and password with sudo ee secure --auth


#9