Cannot install EasyEngine


#1

I’m trying to install EasyEngine for the first time on a VPS with a fresh install (running ubuntu-14.04-x86_64-minimal) and it seems like wget doesn’t do anything,

Imgur

I’ve trying apt -get update after that the issue still there Any suggestions on how I can fix this issue?

Thanks


#2

Hi @BinhDTX

Can you please run the same command but this time without -q flag to wget i.e

wget -O ee rt.cx/ee && suso bash ee

and provide me its output , plus one more thing , in same directory run

cat ee

and provide its output too .

Thanks


#3

Thank you for reply. @Rajdeep_Sharma There is my result

root@sv:~# wget -O ee rt.cx/ee && suso bash ee
--2015-06-19 03:47:53--  http://rt.cx/ee
Resolving rt.cx (rt.cx)... 192.99.10.169
Connecting to rt.cx (rt.cx)|192.99.10.169|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://raw.githubusercontent.com/rtCamp/easyengine/master/install [following]
--2015-06-19 03:47:54--  https://raw.githubusercontent.com/rtCamp/easyengine/master/install
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 199.27.79.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|199.27.79.133|:443... connected.
ERROR: cannot verify raw.githubusercontent.com's certificate, issued by '/C=US/O=DigiCert Inc/OU=www.digicert.com/CN=DigiCert SHA2 High Assurance Server CA':
  Unable to locally verify the issuer's authority.
To connect to raw.githubusercontent.com insecurely, use `--no-check-certificate'.

#4

Hi @BinhDTX Its typical ssl certificate issue , apply the following fix .

run

wget -qO ee rt.cx/ee --no-check-certificate && sudo bash ee

and this should do it

Alternatively

Download this file https://raw.githubusercontent.com/bagder/ca-bundle/master/ca-bundle.crt

then run the following sequence of commands:

sudo cp ca-bundle.crt.crt /usr/local/share/ca-certificates/ca-bundle.crt

sudo update-ca-certificates

sudo update-ca-certificates --fresh

or alternatively

sudo apt-get install ca-certificates

Let me know if this fixes the issue

Thanks


#5
source /etc/bash_completion.d/ee_auto.rc

EasyEngine (ee) installed/updated successfully
EasyEngine (ee) help: http://docs.rtcamp.com/easyengine/

Awesome :slight_smile: thank you so much.

I can installed EasyEngine now.


#6

I had the exact same problem. Also with ‘Ubuntu 14.04 64-bit Minimal’. It ‘worked’ after

(sudo) apt-get install ca-certificates

I had to remove sudo, because that gave error:

-bash: sudo: command not found

Then I did following, but without sudo:

wget -qO ee rt.cx/ee --no-check-certificate && sudo bash ee

EDIT: Well, my problem seems to be that sudo wasn’t installed with ‘Ubuntu 14.04 64-bit Minimal’. So I installed it, which solved my sudo problem.

apt-get install sudo

The CA problem was solved by:

sudo apt-get install ca-certificates

Thanks!


#7

Hello @BinhDTX

I hope your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further.


#8