Cannot allow access to acme-challenge for Letsencrypt


#1

Hi everyone,

I am desperate and have tried for hours and days to make it work but still nothing. I wanted to use Let’s Encrypt with my wordpress ubuntu server, and for that I need to allow .well-known to do the acme-challenge. I have tried everything, every combination possible, every guide on the internet, and still cannot allow access to .well-known. I don’t know what to do anymore.

I added rules to locations.conf, to each server-available file, every possible rule combination, redirected to another folder for /.well-known/acme-challenge following some guides to centralize licenses, still nothing. What am I missing?

I used EasyEngine for the installation and the guide on EE for letsencrypt in the beginning which also didn’t work, and then tried everything else. What else should I check, what other thing could be preventing me?

BTW, I can’t use the EE direct command to automatically configure letsencrypt, because the domain name I used for EE is the domain I will be actually using later, but for now I am using a temporary dyndns domain for development, and I want to get the certificates for the temp domain, and not the actual domain which I will use later. Hope I explained that well.

I have a VM running ubuntu on my pc for the server, and I am using No-IP for a dyndns. Still that should not change anything, because when I try to open .well-known, I get a Forbidden message from Nginx, so it does reach the server, but Nginx doesn’t allow. Help!


#2