Can not update wp basic to wp basic


#1

I was trying to enable HHVM to my site using ee siteupdate example.com --wp --hhvm. But it always shows can not update wp basic to wp basic. How can I enable HHVM to my existing site. I just upgrade easyengine to 3.1.0


#2

Can you try ee site update example.com --hhvm?

No need to pass --wp flag.


#3

Hi Sir,

I think it worked but update failed with new error.

Adding repository for HHVM, please wait ...

Updating apt-cache, please wait … Installing packages, please wait … Restart : hhvm [OK] Reload : nginx [Failed] Backup location : /var/www/example.com/backup/16Apr2015113555 Backing up database [Done] Setting up NGINX configuration [Fail]

I ran tail /var/log/ee/ee.log

2015-04-16 11:36:37,754 (DEBUG) ee : Checking generated nginx conf, please wait ...

2015-04-16 11:36:37,819 (DEBUG) ee : Command ‘[‘nginx’, ‘-t’]’ returned non-zero exit stat us 1 2015-04-16 11:36:37,819 (INFO) ee : [Fail] 2015-04-16 11:36:37,819 (DEBUG) ee : ‘created nginx configuration failed for site. check w ith nginx -t’ 2015-04-16 11:36:37,820 (ERROR) ee : Update site failed. Check logs for reason tail /var/ log/ee/ee.log & Try Again!!! 2015-04-16 11:37:51,057 (DEBUG) ee : logging initialized for ‘ee’ using LoggingLogHandler 2015-04-16 11:37:51,389 (DEBUG) ee : [’/usr/local/bin/ee’, ‘log’] 2015-04-16 11:37:51,390 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers .base.EEBaseController object at 0x7fc115ef8eb8> 2015-04-16 11:37:51,395 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.log .EELogController object at 0x7fc115f02400> 2015-04-16 11:37:51,398 (INFO) ee : Initializing EasyEngine Database


#4

Hello,

Just an update.

I tried to run nginx -t it shows error.

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok nginx: [emerg] listen() to 0.0.0.0:22222, backlog 511 failed (98: Address already in use) nginx: configuration file /etc/nginx/nginx.conf test failed

Then I ran fuser -k 80/tcp then ran nginx -t again. Error was gone. :slight_smile: Restarted nginx after, and it worked! :smiley: Thanks!


#5

@seyntjim

Glad to know your problem solved


#6

Hi @seyntjim

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#7