Can not update from ee 4.0.6 to 4.0.10 with ee cli update


#1

Hi
I can not update from ee 4.0.6 to the lastest version 4.0.10 with the command ee cli update. I get this error:

                                                                                         
         Error: Encountered error while processing remove-global-ee-containers in EE\Migration\ChangeGlobalServiceContainerNames::remove_global_ee_containers. Exception: Unable to remove global service containers 
         Error: Errors were encountered while processing: 20181225063950_service-command_change_global_service_container_names.php                                                                                   
         Unable run change-global-service-container-name migrations.                                                                                                                                                 
                                                                                                                                                                                                                     
                                                                                                                                                                                                                     

Error: The downloaded PHAR is broken, try running ee cli update again.

Can anyone help, please?


#2

I am having a similar problem updating from 4.0.9 to 4.0.10

This is what I am seeing -->

Running ee cli update again produces the same result.


#3

I too have the same problem:

     Error: Encountered error while processing remove-global-ee-containers in EE\Migration\ChangeGlobalServiceContainerNames::remove_global_ee_containers. Exception: Unable to remove global service containers
     Error: Errors were encountered while processing: 20181225063950_service-command_change_global_service_container_names.php                              
     Unable run change-global-service-container-name migrations.                                                                                            

Error: The downloaded PHAR is broken, try running ee cli update again.


#4

hello togheter!

doesn anyone found a solution for this problem?
i have the exacr same error - every idea a welcome!

thanks!


#5

Too bad that none of the pros has an answer…

I solved my problem this way:

  • Backup every site
  • Set up a new server
  • Installed ee v4.0.10
  • Installed all sites
  • Restored the backups

Maybe it’s not the best way to deal with this problem, but it worked. I did it because my le certificates did not auto-renew (wildcard) and I ran out of time. Only v4.0.10 has the new auto-renew command…


#6

Thanks patric for your reply!

I think i have todo the same as you.

Cheers!
stefan


#7

Yup, due to my ignorance and the deafening silence in here, that was the way I “solved” it too! :smiley:


#8

@ terencemilbourn Today I tried to update from 4.0.10 to 4.0.12 - but it also failed. It looks like I can not update. Which version do you run? Can you update now?