Can I add media to messages in BuddyPress?


#1

Hi again, Still working on our new site and wondered if the rtmedia pro version provided functionality of adding media to messages in BuddyPress (aas well as in comments)? Cheers.


#2

Nope. You can use this plugin for private message attachments though:

Despite no updates for 2 years still works fine, too.


#3

Thanks @illusionsglass, I had looked at that a few times but had been nervous of starting a new site relying on an old plugin.

Well I’ve just tested it and although it hasn’t broken the messaging itself it breaks it completely when a jpg is included (with the correct admin settings); message such as these appear…

Warning: Missing argument 2 for wpdb::prepare(), called in /home…/wp-content/plugins/buddypress-message-attachment/includes/actions.php on line 113 and defined in /home/…l/wp-includes/wp-db.php on line 1152

Warning: Cannot modify header information - headers already sent by (output started at /home/…/wp-includes/wp-db.php:1152) in /home/…/wp-includes/pluggable.php on line 1178

So no-go for that I think for me - but worth a try!

But would be a good additional functionality for the rtmedia pro, don’t you think?

Cheers.


#4

It would be a cool addition, I agree.

To fix the plugin errors you see, remove the file extensions already in the list, make the plugins settings look like this:

jpg,gif,png,zip,pdf,whatever

Notice the comma, and NO SPACES. The spaces cause this error. :slight_smile: Aint the best written, but it does work! :slight_smile:

Ben


#5

Thanks - yes i saw the image showing the correct settings and my settings were only jpg - so no commas and no spaces at all. So any other suggestions?

Cheers.


#6

I’ll be damned. The author of that plugin just released a new version 2 years later. It came out today. :slight_smile: Try the new version! I’m installing it on my machines now…


#7

A lucky coincidence! I’d be interested to know how you got on with it and if you think it’s OK to use. Cheers.


#8

For me, the “Choose File” button didnt work. :slight_smile: So I reverted back to the old version, to debug this one later.


#9

Thanks for your feedback - hopefully the plugin author will get the feedback and update it again soon. I’ll keep my eye on it!


#10