Cached using Nginx-Helper Comments Coming Through on Ajax Json Response


#1

I am using a script called aMember to handle content protection.

The script embeds subscription forms in specific URLs like:

example-site/membership/login

One particular form does not work when I click the submit button.

I checked the network communication in Chrome dev tools and I noticed the following response from the server when I clicked submit:

{"ok":true,"url":"http:\/\/example-site.com\/membership\/member"}  

The json response is fine, but the comments after it are causing issues with the form.

Is there some way to prevent this? If I have to, I am ok with turning off the comments entirely.

I changed the theme to the default, and it still does the same.

Not sure if this post is public, so I didn’t send specific information on my server, etc. You guys did set up my server stack a couple of months ago, and did a very nice job, by the way.

If you need more information, would be happy to provide that.

Thanks,

JW


#2

You need to turn “Enable Nginx Timestamp in HTML” option off in WordPress Dashboard >> Settings >> Nginx Helper

Please see attached screenshot.

Attachment Link(s):

https://rtcamp.com/wp-content/uploads/rtMedia/topics/55110/2014/01/Nginx-Helper-comment-html.png


#3

Rahul,

I’m so sorry, of course! Slipped my memory that this option existed in the Nginx-Helper settings.

You guys do a great job!

My apologies, and thank you!

J


#4

No issues. Glad to know I could help! :slight_smile:


#5