Cache Redis is not working


#1

Hello.

I did a fresh installation with the following commands.

ee site create example.com.br --wpredis --hhvm --pagespeed

But it seems that fastcache continue working.

In cleaning:

  • Restart: memcached [OK]
  • Cleaning MemCache
  • Cleaning NGINX FastCGIcache <<<<<<<
  • Cleaning opcache
  • Cleaning Redis cache
  • Cleaning PageSpeed cache

And in the header:

  • X-Cache: HIT
  • X-Cache-2: BYPASS

You need some more settings?


#2

Helo @edisoncosta

With

ee clean --all

EE fire clean up process for all FastCGI, Memcache, OPcache , PageSpeed or Redis cache available in your system . It is perfectly alright when you find “Cleaning NGINX FastCGIcache” here. Your site is being cache with redis only .

And in the header:

X-Cache: HIT

X-Cache-2: BYPASS

Here is the meaning of these headers

X-Cache => indicates the fetch status from cache.

X-Cache-2 => indicates cache store status.

If you get HIT for X-Cache means you dont need to store in cache so X-Cache-2 gives BYPASS.


#3