Cache purging doesn't work on post creation/update


#1

Hi!

I have trouble with cache purging: when I am pressing the button “purge all” - it works fine.
But when I trying to create/update post - it doesn’t want to purge cache. I have checked the users of PHP and Nginx - they both running under same user.
I took the configuration from the tutorial, and modified it in one thing - I have added geoip, so the cache key looks like this: fastcgi_cache_key “$geoip_country_code$scheme$request_method$host$request_uri”;
I suppose that I need to change something in rewrite rule, am I right?

Thanks!


Redis_cache with geoip target country
#2

purge-cache nginx-module will always purge only one variation of by default.

In your case, $geoip_country_code will be substituted based on server's value only.

You can try "Purge Cache" option in admin bar from http://wordpress.org/plugins/nginx-helper/ plugin.


#3