Button Disappeared


#1

Hello, i have an issue with rtMedia. The button to upload a new media in buddypress totally disappeared. At the moment is possible to upload pics ony in comments. I have an urgent need to solve this problem since i made a campagin to sponsor my website and I really need this function that worked since yesterday. Please help.

Thank you


Post Update Button No Longer Showing after 4.3.2 Update
#2

Hello @Roberto_Cosentino,

Can you specify the theme you are using? If this happened after the latest rtMedia plugin update and you are using the kleo theme then there is some conflict exists between BuddyPress’ JavaScript and the overridden JavaScript of BuddyPress used by the kleo theme.

We have already notified kleo theme developers regarding this issue and hopefully will find some workaround soon.

Meanwhile, to make it work you can use below quick fix under custom CSS box at rtMedia > Settings > Custom CSS tab:

#whats-new-content.active #whats-new-options{
    display:block;
}

I hope that helps you. Thanks.


#3

Thank you for your answer. Actually i just noticed that Buddypress did not work at all. Yes I use Kleo and post updating totally disappeared, not only rtMedia. I will try to use the code you gave me, do you think it will work even for new post? Thank you so much.


#4

@pranalipatel thank you so much!! it worked!!!


#6

Dear @pranalipatel, I have the same issue with the same theme. I added the rule

whats-new-content.active #whats-new-options{ display:block; }

but the buttons - even though they appeared - are still invisible, transparent. Any idea how to make them colored as they used to be?

Thanks a lot and My Best Regards, Gian


#7

I am also having the same issue. I tried pasting in the css but it didn’t work. In the meantime I have had to disable rtmedia. Is there another fix for this or will it be fixed in the next release?


#8

Hello @Gian_Lorenzo_Lagna,

If you want to change the background color for that “Post Update” button then please try below custom css:

#whats-new-submit #aw-whats-new-submit{
background: red;
}

@Jack_Potter,

Please, once try switching to your parent theme or any other default WordPress theme and check if you still face the issue. Let me know which theme you are using. I will check if ( it’s free ) I can regenerate the issue at my end.

Thanks.


#9

hello pranalipatel ,

with your css code : #whats-new-content.active #whats-new-options{ display:block; }

The buttons are invisible. Yet when you mouse over the area where should be the buttons, the mouse reacts. But the buttons are invisible. Buttons appear only if you want to comment on an existing publication. :frowning: It is also impossible to publish a media or publication directly on its personal space

with your css code : #whats-new-submit #aw-whats-new-submit{ background: red; }

I also changed the color as you suggested but nothing appears :frowning:

I use the theme kleo

Is it possible to use an older version of rtMedia? Would this help to solve this problem which is recurrent for hundreds of people since the update of RTMEDIA

Sorry for my english, i’m french


#10

Hello @emma,

Could you please, once switch to the parent theme of kleo and check if the issue still persists?

It should work as kleo theme developers also suggested the same CSS till they release a new version. I hope you have tried addint it under custom CSS box at rtMedia > Settings > Custom CSS tab:

#whats-new-content #whats-new-options,
#whats-new-content.active #whats-new-options {
    display: block;
}

Thanks,


#11