BUG: @mention and photos don't work together


#1

I came across a bug with the plugin. When I’m posting an activity update, if I attach an image, and in the status update, write something that has a @someone, the photo doesn’t show up in the status update.

Please look into this and let me know if it is something that can be fixed easily.

Thank you!


#2

Hi maggie,

In our end it works perfectly. Check the screenshot attached below. Works fine in different browsers and default WordPress themes. You can also check our demo at http://demo.rtcamp.com/rtmedia/ where it works as supposed to. Thanks.

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/70008/2014/08/support1.png


#3

Hi Sumeet,

Thanks for testing. I just did a default installation with the most recent version of Wordpress, Buddypress, and RT Media free version, and I’m still getting the same issue.

Are you using the Pro version of the plugin on the demo site?

Thanks,

Maggie


#4

Hi Maggie,

Yes we have rtMedia-PRO activated in our demo site, but it has nothing to do with pro version. We had checked with free version as well and is working fine. Make sure you are using BuddyPress mention name to mention a user.


#5

this was a private reply with post_id 70127


#6

this was a private reply with post_id 70142


#7

this was a private reply with post_id 70156


#8

Hello, I am receiving this same issue. The image shows when I refresh but on initial post it does not, thus making people think the image did not upload.
Has this been looked into and what I can do to solve this?


#9

Hi Maggie,

This is the debug info of our demo site as you requested.

Home URL http://demo.rtcamp.com/rtmedia
Site URL http://demo.rtcamp.com/rtmedia
PHP 5.5.10-1+deb.sury.org~precise+1
MYSQL 5.6.15
WordPress 3.9.1
BuddyPress 2.0.2
rtMedia 3.7.3
OS Linux
Imagick ImageMagick 6.6.9-7 2014-03-06 Q16 www.imagemagick.org
GD 2.1.1-dev
[php.ini] post_max_size 200M
[php.ini] upload_max_filesize 200M
[php.ini] memory_limit 256M
Installed Plugins Akismet by Automattic version 3.0.1,
bbPress by The bbPress Community version 2.5.4,
rtMedia Instagram by rtCamp version 2.1.4,
rtMedia Photo Tagging by rtCamp version 2.2.4,
rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 3.7.3,
BuddyPress by The BuddyPress Community version 2.0.2,
Contact Form 7 by Takayuki Miyoshi version 3.9,
Google Analytics for WordPress by Joost de Valk version 4.3.5,
Gravity Forms by rocketgenius version 1.7.9,
IJM Theme Switcher Bar by Iain J McCallum version 2.0,
myCRED by Gabriel S Merovingi version 1.5.1,
Ninja Forms by The WP Ninjas version 2.6.5,
P3 (Plugin Performance Profiler) by GoDaddy.com version 1.5.1,
Qr Code Adv by Branimir Ivanov version 1,
Quick Page/Post Redirect Plugin by Don Fischer version 5.0.6,
Rewrite Rules Inspector by Daniel Bachhuber, Automattic version 1.2.1,
rtAccount Login by $trik3r version 1.01,
Google Analytics plugin to track page scrolling by rtCamp version 1.0.0,
rtAntiSpam by rtcamp version 1.0,
rtMedia Pro by rtCamp version 2.4.2,
rtMedia Widgets by rtCamp version 1.0,
rtSocial by rtCamp, rahul286, rutwick, saurabhshukla, HarishChaudhari, faishal, 5um17, JoshuaAbenazer version 2.1.15,
WooCommerce by WooThemes version 2.1.11,
WordPress Importer by wordpressdotorg version 0.6.1
Theme Name InspireBook
Theme Version 1.2.3
Author URL https://rtcamp.com/
Template Overrides themes/pt-rtmedia/rtmedia/media/album-gallery-item.php,
themes/pt-rtmedia/rtmedia/media/album-gallery.php,
themes/pt-rtmedia/rtmedia/media/album-single-edit.php,
themes/pt-rtmedia/rtmedia/media/media-gallery-item.php,
themes/pt-rtmedia/rtmedia/media/media-gallery.php,
themes/pt-rtmedia/rtmedia/media/media-single-edit.php,
themes/pt-rtmedia/rtmedia/media/media-single.php,
plugins/buddypress-media/templates/media/uploader.php

@maggie and @jjfaitz,

I suggest you to check it with WordPress default theme and with other plugins disabled.


#10

For anyone that has the same issue out there. Here’s the fix to the problem which looks totally irrelevant but it worked.

Go to rtMedia -> Settings -> Privacy -> Turn on Enable Privacy

That apparently did the job.


#11

Hi Maggie,

We have found the issue. We are looking into it and will be fixed in future update of rtMedia.


#12