Buddypress Missing Member Profiles


#1

Hello,

I installed Buddypress onto my Wordpress site and seemed to be going along alright with the site looking how I wanted also adding a few widgets. In testing the site was working fine but all of a sudden the "Members" section as developed a fault.

I'm getting this message which is printed below.
Fatal error
Cannot access empty property in

/home/content/46/7415846/html/administrator/wp-content/plugins/buddypress/bp-core/bp-core-template.php

on line

823

Any help is appreciated.

Thanks

Steve


#2

Can you please tell us which version of BuddyPress you are using, and which widget you tried to add and also, which page you were viewing when you got this error?


#3

Hi,

I’m using Buddypress Version 1.6.1, the last plug in installed was MyMood version 1.2 which I’ve now deactivatedwith no change to the site.

The page with the error is the members profile page. We can log in click on another member and see their profile no problem then when we click our own profile that’s when we get the Fatal Error message.

The “Forum” link is missing too when the error mesage is displayed.

Profile  
Friends  
Messages  
Activity  
Groups  

The website is http://www.weddingsingeruk.co.uk/

Just thought of something, I edited the Sample page to change it to Contact Us. Could that be the problem?

I also located /home/content/46/7415846/html/administrator/wp-content/plugins/buddypress/bp-core/bp-core-template.php in the FTP file manager at Go Daddy

Thanks

Steve


#4

Buddy, I’ve tested your site, as you already have accidentally found out the culprit is BuddyPress Extended Settings, all I did was check out what exactly in BuddyPress Extended Settings is causing your problem.
I’ve still not found why, but the error appears only when you try to change the position of the “Forum Tab” link.
So now you can safely turn on the BuddyPress Extended Settings plugin again, but just make sure to uncheck the checkbox right next to the “Forum Tab” in the Profile Settings(As highlighted in the attachment below).
Will inform the plugin developer about the problem maybe he’ll solve it in the next update.

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/10067/2012/08/bbextendedsettings.png


#5

Hi,

Thank you for all your help.

I’ve turned on the BuddyPress Extended Settings tab and unchecked the forums tab, the site is working perfectly.

Again thank you

Steve


#6