Blogger-to-wordpress-redirection plugin not working


#1

Installed plugin. Ran it, added code to blogger. Running ‘verify configuration’ produces a correct set of URLs: however, the redirection does not actually occur…instead, I get a ‘page not found’ error on the new WP blog.

For example:
Clicking this link » http://www.sailingtotem.com/2013/02/nudging-north-in-raja-ampat.html
Should redirect to » http://www.sailingtotem.com/2013/02/nudging-north-in-raja-ampat/

http://www.sailingtotem.com/2013/02/nudging-north-in-raja-ampat/ works, but http://www.sailingtotem.com/2013/02/nudging-north-in-raja-ampat.html does not redirect to that URL.

Campers, I would be so grateful for your help! I am supposed to take off on a 3 day voyage today but don’t want to leave before this is fixed. :frowning:

POSSIBLE FACTOR? I’ve tried another recommendations from RTCamp for permalinks in my migration: I installed and ran the fix.php suggested in https://rtcamp.com/blogger-to-wordpress/tutorials/permalink-seo-migration. It appeared to run correctly (e.g., I got the ‘DONE’ message).

ALSO: I tried to follow recommendations here as well- https://rtcamp.com/blogger-to-wordpress/tutorials/video-blogger-to-wordpress-migration-complete-user-guide/
However, I could not complete htem, because can’t open anything on http://bloggertowp.org/. It only produces errors like "this webpage is not available). I don’t know if that’s a problem at http://bloggertowp.org/ or if it’s a function of my current internet access.


#2

@behang

I can suggest you to keep .html in post URL structure, in that way the one to one redirection will work fine and also it will help to keep SEO.

Another thing, since you were already using the same custom domain sailingtotem.com on blogger and it is using on WordPress blog also, hence I can suggest you to just use .htaccess rules for the redirection of URLs which are provided in our DIY article. (No need to use our redirection plugin).


#3

Nitun, thanks so much for the reply. Big error on my part, I was so careful to change the default URL structure but then missed the whole .html append before I imported everything! But if the .htaccess edit fixes that, no worries.

But- here’s the thing. Although if I search in my root directory I find multiple instances of .htaccess, when I look in the actual file structure… it’s not there. Check out the screenshot at this link and tell me if I’m crazy (it’s possible!):
http://cl.ly/image/1X3L2G1J0X3G

The screenshot shows my search in the directory for any incidence of “htaccess” (there are a bunch); behind it is the file list for the /public_html/. Search shows it should be there, but you can see, it’s not! I’m really confused! Any idea what’s happening?

THANK OU!


#4

You can use the .htaccess file which is under /public_html/ folder.


#5

Thanks Nitun. I understood it was a file called “.htaccess” inside /public_html/, when I use my hosting service file manager to look in /public_html/ … I couldn’t see it. But when I looked with FileZilla… HELLO! So somehow it’s masked. Anyway, I made the change (I added the recommended text above #END Wordpress, as pasted at the very bottom here), and I changed the permalink to custom /%postname%/.html, and now it’s working great. Goodbye plugin, yeah! I’d rather have all new posts just be /%postname%/ format but I’ll deal with that later, once I know I’m not serving 404 errors.

But… this uncovers a new problem. Before migrating to Wordpress, following your permalink SEO migration guide, I started to redirect my Blogger subdomain (sv-totem.blogspot.com) to the custom domain (www.sailngtotem.com). That worked fine, except now that the migration is done, any sv-totem.blogspot.com link no longer redirects directly to the www.sailingtotem.com link: it goes to a Blogger page that announces “You’re about to be redirected…” etc. that requires user to click ‘yes’ or ‘no’. Yikes, that’s terrible. I thought it would continue to seamlessly redirect posts to www.sailingtotem.com? Did I miss something in your guide?

BEGIN WordPress

RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

#Redirect archives
RewriteRule ^([0-9]{4})([0-9]{1,2})([0-9]{1,2})_archive.html$ $1/$2/ [L,R=301]
#Redirect labels/categories
RewriteRule ^search/label/(.*)$ category/$1/ [L,R=301]

END WordPress


#6

If you imported content from blogger blog and that time if this URL sv-totem.blogspot.com was active, then our plugin is required. There are some meta values stored in post editor under the custom fields.
And if the content imported are done with custom domain only www.sailingtotem.com, then redirection from sv-totem.blogspot.com to www.sailingtotem.com do not work.
You may need to hire our technical team to work on such critical migration. We can manage both the URL redirection. Feel free to get in touch with me at nitun.lanjewar@rtcamp.com if you want to hire us.

Thanks,
–Nitun


#7

At the time I imported content from the blogger blog to Wordpress, the URLs for sv-totem.blogspot.com were redirecting to www.sailingtotem.com. Can you clarify if that’s considered active- if I just need the plugin, or if it’s more complicated than that?

I made the URL change from subdomain to custom domain prior to migration based on following the instructions in your permalink SEO migration guide (which other than working through this, has been fantastic!).

I’d sure like to get rid of the interim Blogger page, hopefully it’s not difficult.


#8

Kindly check in your post editor section, if custom field values are like:
Blogger_blog = sv-totem.blogspot.com
blogger_permalink= some url value

Then you need to use our redirection plugin. and then you need to add manual entries for blogger_blog for custom domain also www.sailingtotem.com via SQL query.

Or the custom field value for blogger_blog is www.sailingtotem.com, then no need to use our plugin.

Thanks,


#9

Hi Nitun,
Looking at the post editor section in WP, not sure I see any custom field values at all- is this where I should be looking?
http://cl.ly/image/0u0m2U1p2v2h

THANK YOU!
Behan


#10

Check the screen option. See attached image Then you will find custom field below the post editor.

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/67305/2014/07/Selection_047.png


#11

Nitun, I figured it out. Everything redirecting as it should now. Thanks. :slight_smile:


#12

Glad to know that :slight_smile:


#13