Blank and nginx default page


#1

Dear EasyEngine community,

I’m hoping somebody can help me out here. Currently we are running wordpress on our own custom stack but we are trying to get rid of some overhead and are switching over to EasyEngine.

However, we can’t get it to work. I have a completely clean server at Linode, just did a fresh install. If I run wget -qO ee rt.cx/ee && sudo bash ee and sudo ee site create example.com --wp, and I go to my domain I get nothing. If I connect straight to the IP-address I am being send to the Nginx default ‘welcome’ page.

What am I doing wrong? I have completely wiped my server numerous times, and reapplied the DNS server. Tried running the individual ‘–install’ commands, running through different root accounts, did a manual install of the components… but I am getting nothing.

I googled the issue but I can’t seem to find anything close to a solution. (Tried installing CURL and resetting time-zone, did not work).

Any help is greatly appreciated, Thanks!


#2

The short answer is that you are NOT necessarily doing anything wrong.

EasyEngine is capable of installing and managing multiple websites, per IP address. Thus, the output you are seeing is the output generated by the html file, found at:

/var/www/html/index.Some-Distro-Name.html

…which is used in /etc/nginx/sites-available/default and /etc/nginx/sites-enabled/default

If you’ve correctly pointed your domain, try viewing the website by typing in its URL.

If you want the IP Address to deliver a specific website, you will likely have to redefine the symbolic link for “default” to the website of your choice.


#3

@bamajr thanks for your reply! This is very helpful.

If I type in my URL directly (eg. ‘example.com’) the page loads forever, but eventually responds with a ‘The connection has timed out’-error. You can try it yourself at http://crossroadshomes.com/.

If you want the IP Address to deliver a specific website, you will likely have to redefine the symbolic link for “default” to the website of your choice.

Shouldn’t ee do this by default? And if not how can I do this manually? My DNS is setup correctly, and ee already added ‘example.com’ in my host files…

Thank you,


#4

When I try your URL, I get the 403 Forbidden HTTP Status Code - usually meaning I’m requesting a resource your server cannot provide (See: Resolving the 403 Forbidden Error (or HTTP Status Code)

My initial thought is that your website may not be enabled.

Try this:

ls /etc/nginx/sites-available

Is your website listed?

If it is, then try this:

ls /etc/nginx/sites-enabled

Is your website listed?

If it is not, try:

ee site enable example.com

#5

Thanks @bamajr for your help!

Site is working! I think my provider did not propagate the host so I was getting a blank, I was finally able to receive the 403 error after waiting a couple more hours. The link you included in your post was very helpful, for some reason I was missing a “index.php” in the “sites-available/enabled”.

Website seems to work correctly now. The new ee stack seems to be a bit slower than our old/current stack, but the difference is minimum and we have not played around with the caching options yet. Last thing left is that we are having some issues with the VimbAdmin but will open a new ticket for this if we can’t figure it out.

Thanks again for all your help.


#6

Hi @MeRuud

I hope this issue has been satisfactorily resolved, Incase of no further continuation on this issue, we will be closing the issue after a duration of 48 hours.

Thanks.


#7

Yes, issue has been resolved and can be closed.

Thank you,


#8