Basic config doesn't work :(


#1

I'm trying to install WP on my BeagleBone which runs under Ubuntu 13.04. Since I have already a web-app running I get almost nuts cause I have no idea why the config of WP fails.

I tried some very basic config but this fails as soon as I wanna start the init process. The debug says ' FastCGI sent in stderr: "Primary script unknown"' I checked if the file exists - and yes it is there and accessible. One problem I figured out was the open_basedir didn't allow to access the dir-structure. But this I fixed as well.

So I'm little bit running out of ideas what the root-cause of problem might be. Any ideas what to check additonally?


#2

Sorry for late reply.

Your nginx config looks fine. What about your PHP config?

Have you installed PHP, Nginx, etc using - http://rtcamp.com/tutorials/linux/ubuntu-php-apc-mysql-postfix/


#3

After struggling quite a long time I finally solved the issue by moving the extracted folders to a user which belongs to the group www-data. But when I moved the folder-structure back, it still worked and I have no real idea how the folder-structure-permission should be set properly. Especially to have not toooo many rights, just sufficient. Do you have a link with some insights to this?

Anyway the issue why I was looking for support is solved.


#4

I think in your case, php and nginx users are different.

In such case, adding one user to another group and then changing group permission on content can solve problem.

If you wish to keep things simple, you can try - http://rtcamp.com/easyengine


#5