Attach Files button does not attach selected image file?


#1

I installed the free version of this plugin (Version 3.2.12) on my WP 3.8 site… I anticipate buying the full Pro version, but I cannot get it to work right. When I try to test this by selecting a JPG or PNG file to attach to a comment in my profile it does not work…

It allows me to select an image file in the finder window. However, it does not attach the file to my post. Any thoughts? Thank you for any help you can provide.

Attachment Link(s):

https://rtcamp.com/wp-content/uploads/rtMedia/topics/53442/2013/12/Screen-Shot-2013-12-16-at-8.56.44-PM.png


#2

Hi @jderosa3,

Can you please check maximum file size allowed on your server. You can check for it here : your-site-url/wp-admin/admin.php?page=rtmedia-support#debug


#3

Here is a copy of what that page produced… What are your thoughts:

PHP 5.4.13
MYSQL 5.5.30
WordPress 3.8
BuddyPress 1.8.1
rtMedia 3.2.12
OS Linux
Imagick Not Installed
GD bundled (2.0.34 compatible)
[php.ini] post_max_size 8M
[php.ini] upload_max_filesize 128M
[php.ini] memory_limit 256M
Installed Plugins Maintenance by fruitfulcode version 1.3,
Advanced Polls by Extstore version 2.0,
AJAX Thumbnail Rebuild by junkcoder version 1.09,
Akismet by Automattic version 2.5.9,
All-in-One Event Calendar by Timely by Timely version 1.10.5,
Auto Post Thumbnail PRO by Tarique Sani version 1.3,
bbPress by The bbPress Community version 2.5.1,
BP Redirect to Profile for Buddypress by Brajesh Singh version 1.2,
BP Show Friends by imath version 2.0,
rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 3.2.12,
BuddyPress by The BuddyPress Community version 1.8.1,
Business Directory Plugin - PayPal Gateway Module by D. Rodenbaugh version 3.2,
Business Directory Plugin by D. Rodenbaugh version 3.2.3,
Duplicate Posts Remover by Optimum7 version 3.2.0,
Easy WP SMTP by wpecommerce version 1.0.7,
Feed Wordpress SEO Fix by David Nellessen version 1.0,
FeedWordPress by Charles Johnson version 2013.0504,
Google Analyticator by Video User Manuals Pty Ltd version 6.4.5,
Google XML Sitemaps by Arne Brachhold version 3.4,
Gravity Forms by rocketgenius version 1.7.12,
Jetpack by WordPress.com by Automattic version 2.7,
My Wordpress Login Logo by Afsal Rahim version 2.0,
Optimize Database after Deleting Revisions by CAGE Web Design | Rolf van Gelder, Eindhoven, The Netherlands version 2.7.5,
Scalable Vector Graphics (SVG) by Sterling Hamilton version 2.1.1,
Social Count Plus by claudiosanches, felipesantana version 2.7.7,
NextScripts: Social Networks Auto-Poster by Next Scripts version 3.1.0,
SpeakUp! Email Petitions by Kreg Wallace version 2.4.2,
Widget Logic by Alan Trewartha version 0.57,
WooCommerce by WooThemes version 2.0.20,
WordPress HTTPS by Mike Ems version 3.3.6,
WordPress SEO by Joost de Valk version 1.4.21,
Online Backup for WordPress by Jason Woods @ Backup Technology version 3.0.4
Theme Name PowerMag
Theme Version 1.6.0
Author URL http://themeforest.net/user/djwd
Template Overrides plugins/buddypress-media/templates/media/album-gallery-item.php,
plugins/buddypress-media/templates/media/album-gallery.php,
plugins/buddypress-media/templates/media/album-single-edit.php,
plugins/buddypress-media/templates/media/media-gallery-item.php,
plugins/buddypress-media/templates/media/media-gallery.php,
plugins/buddypress-media/templates/media/media-single-edit.php,
plugins/buddypress-media/templates/media/media-single.php,
plugins/buddypress-media/templates/media/uploader.php
Total Albums 1


#4

I have also disabled plugins one at a time and could not find a conflict either… just an FYI… any other debugging that can be done?

Also, When in FireFox using FireBug… I see the following occur in the Console when clicking on the Add Files + button…

Empty string passed to getElementById().
…nction(e){var t,n="",r=0,i=e.nodeType;if(i){if(1===i||9===i||11===i){if(“string”…

domain.com/wp-includes/js/jquery/jquery.js?ver=1.10.2

Is this a JQuery issue?


#5

Hi @jderosa3,

Could you please send your website URL and credentials to my E-mail ID : abhishek.kaushik@rtcamp.com, so that we can debug the issue.


#6

URL and credentials sent.


#7

Got it, thanks.

We will look into it and update you ASAP.


#8

It’s just odd that nothing happens… I was looking for a plugin like this for a while and it seems to be the best out there. Would love to use it on other sites. Let me know what you find out.


#9

Hi @jderosa3,
I checked your website. There is a js error which conflicting with rtMedia uploader.
I also checked by switching to default theme and uploader is working fine.


#10

What JS file is conflicting? Can you tell me a little more info so I can go back to the theme developer and have them look further into this? Thanks for your help!


#11

JS was directly written on the page and not in any js file.

Attachment Link(s):

https://rtcamp.com/wp-content/uploads/rtMedia/topics/53773/2013/12/beta.thedandelionpress.com_.s162671.gridserver.com-js-error.png


#12

no sure exactly what this means… I will have to see what the theme developer says. Thanks for your efforts.


#13

You are welcome @jderosa3.

If you have further queries, feel free to ask us.


#14

#15