Apt upgraded openssl and nginx mainline = problems


#1

DO trusty

Been on mainline for a week, noticed apt was going to allow openssl as well as nginx mainline upgrade. So I went with it. When I tried to update a site afterword it failed.

ee site update example.com --wpfc

ee update failed with

2016-01-12 08:26:09,292 (INFO) ee : Reload : nginx     
2016-01-12 08:26:09,440 (DEBUG) ee : nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful
reload: Job is not running: nginx
2016-01-12 08:26:09,441 (INFO) ee : [Failed]

plugins installed and seem to be caching.

when I issue

ee site update example.com --wp
to revert back I get

can not update wp basic to wp basic

nginx -t passes ok and sites are up, but if i use

ee stack reload --nginx

Reload : nginx [Failed]

if I issue service nginx restart everything is ok.

I believe this is from allowing apt to upgrade nginx mainline though I am not certain. I reverted back and will wait to upgrade. Just thought I would share the issue I was having. Thank you rtcamp you guys rock!


#2

Hi!

I’m having this exact same issue after doing an ee stack upgrade yesterday. Anyone who knows how to solve this?


#3

Hi,

Here is the solution.

Edit your nginx.conf file located at /etc/nginx/nginx.conf and either comment or delete the ssl settings lines or delete them and save the file.

Open /etc/nginx/common/wpfc-php7.conf file and either comment or delete these lines as below:

location ~ /purge(/.*) { fastcgi_cache_purge WORDPRESS “$scheme$request_method$host$1”; access_log off; }

Lastly do not forget to reload or restart nginx.


#4

Well, nginx-mainline uses (mostly) OpenSSL 1.1.0e, nginx-stable (as EE nginx version) uses OpenSSL 1.0.2k, when updated. What’s your OpenSSL version? Please, run $ openssl version


#5