App Folder Permissions Workaround for FTP User


#1

Hi all,

I’m aware there’s a known issues surrounding permissions for the app folder outside of root in EE v4 and I’ve seen a couple of posts that seem to address a couple of workarounds, but I’m yet to find anything that works for me. I appreciate that this is a fix that will happen in a later release, but anything that can help me out now would be great.

My main issue is allowing a friend, who’s web space I host, FTP access to his htdocs directory. I really don’t want to give him root access, as I’m sure you’ll agree isn’t a great idea. Is there anything I can do to make this work until the next release?

Thanks for your help, really appreciate it.

Steve


#2

Please check this out https://easyengine.io/handbook/configure-sftp-on-ee4-server and see if it works for you.


sFTP for each site
#3

I tried following that tutorial for EE4 and it still says the user does not exist when I do a check.


#4

Hey buddy,

Thanks for your reply. Unfortunately, the user in question needs to run clear FTP due to the software he runs to update the website. I know, it’s idiotic and I’ve explained as much to him, but I can’t seem to change his mind. So I need a way of accessing his www folder using clear FTP. :frowning:


#5

I’m not using EE anymore but I was able to read/write to the docker’s volume by creating a new user, same username as host, inside the container.

  1. Open shell into the EE site container
  2. Create new user, same username as your ssh user
  3. Add user to web server group (probably www-data)
  4. chown -R g+w /path/to/wordpress/inside/container

I’ve never tried but this could probably be replicate for FTP users. The FTP user just needs to be in the same group as the web server.