Apache page after installing wordpress theme


#1

Good day.

I had a wordpress with W3C install via EE and everything was working fine. Then today I purchased a premium theme and after the installation of that theme the domain name brings up an apache default page.

What should I do to get my website back?

I am running Ubuntu-14.04 x32 and latest 3.7.4 EasyEngine.

Thank you.


#2

EE doesn’t support Apache so where does it come from?


#3

I have no idea. That is why I was wondering about it. Maybe it comes with Ubuntu template… If I do apt-get remove apache2 it gets removed but then I still have the apache page.


#4

Did you remove Apache completely? Just in case make sure you stop apache2 and restart nginx:

sudo service apache2 stop

and then

sudo service nginx restart

In Apache, any domains that are hosted on the server are configured in “/etc/apache2/sites-available/“ so make sure that directory is removed.

How many sites do you host? And how did you install a premium theme, manually or via Wordpress?


#5

I only host 1 site and it was a test site to make sure the setup works. The name of the theme I installed is Flatsome and it is from Codecanyon. There are several plugins come bundled with the theme. After I installed the theme it offered me to install required plugins to which I concented. After the installation I got that apache default page. I will try to recreate the issue and report back if Tyrro’s commands helped.

Thank you for the suggestion tyrro


#6

I’m very familiar with Flatsome theme and in fact use it on one of my clients website and I never had such a problem. I think the issue comes from a fact that you host a single site and it has something to do with default server configuration located in /etc/nginx/sites-enabled/default

Can you check if you have your domain name listed under both /etc/nginx/sites-available and /etc/nginx/sites-enabled ?

And, please post the content of the following command:

cat /etc/nginx/sites-enabled/default


#7

Tyrro, thank you for taking the time.

The domain is listed under both, /etc/nginx/sites-available and /etc/nginx/sites-enabled.

Here is the content of the /etc/nginx/sites-enabled/default

` ##

You should look at the following URL’s in order to grasp a solid understanding

of Nginx configuration files in order to fully unleash the power of Nginx.

http://wiki.nginx.org/Pitfalls

http://wiki.nginx.org/QuickStart

http://wiki.nginx.org/Configuration

Generally, you will want to move this file somewhere, and start with a clean

file but keep this around for reference. Or just disable in sites-enabled.

Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.

Default server configuration

server { listen 80 default_server; listen [::]:80 default_server;

    # SSL configuration
    #
    # listen 443 ssl default_server;
    # listen [::]:443 ssl default_server;
    #
    # Self signed certs generated by the ssl-cert package
    # Don't use them in a production server!
    # include snippets/snakeoil.conf;
    #
    # ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # donБ─≥t use SSLv3 ref: POODLE
    # ssl_ciphers HIGH:!aNULL:!MD5;
    # ssl_prefer_server_ciphers on;

    root /var/www/html;

    # Add index.php to the list if you are using PHP
    index index.html index.htm index.nginx-debian.html;

    server_name _;

    location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
            try_files $uri $uri/ =404;
    }

    # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
    #
    #location ~ \.php$ {
    #       include snippets/fastcgi-php.conf;
    #
    #       # With php5-cgi alone:
    #       fastcgi_pass 127.0.0.1:9000;
    #       # With php5-fpm:
    #       fastcgi_pass unix:/var/run/php5-fpm.sock;
    #}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~ /\.ht {
    #       deny all;
    #}

}

Virtual Host configuration for example.com

You can move that to a different file under sites-available/ and symlink that

to sites-enabled/ to enable it.

#server {

listen 80;

listen [::]:80;

server_name example.com;

root /var/www/example.com;

index index.html;

location / {

try_files $uri $uri/ =404;

}

#}

`

My apologies for the large fonts. I don’t think this forum paste the output of command with proper formatting


#8

I don’t see any issues with the config. What is your domain name?


#9

Tyrro,

I ended up moving that domain name to another server. I thank you for your help. I will continue testing the EasyEngine server with that theme. I think the Apache page happened when I installed the demo data and plugins that came with the theme. Without it it was fine. I will try to replicate the issue and post it back here.

Thanks again!


#10

I have the same theme, same plugins and same demo data and no issues. Is it a new demo content that comes with newest v.3.0?


#11

I am not familiar with the old one. I installed the theme then I installed the recommended plugins then followed the prompt and installed the demo content. When I checked the site I had the apache2 default page. I tried apt-get remove apache2. It got removed or at least it looked like something was getting removed but yet when I pull the domain name the default page would still show. I will try to recreate the same issue when I get home (Im on the road now) and see if I can get it solved and maybe you could see what I am talking about.

The flatsome version is 3.0.28


#12

Did you reboot the server after removing Apache?


#13

Possible reasons of this error.

You have typo in domain name during site creation.

For your information Your server had by default apache server installed And its files like index page located at /var/www/html

If you will open this directory you will find two html files in it Index and index.nginx-debian

So default configuration file has instructions to show index page in case 404 etc but when you will visit your site by Ip then you will see content of index.nginx-debian

Hope this will help


#14

Thank you all for suggestions.

Reply to portofacil - I did reboot after removal of Apache - it didnt help

Answer to hardeep - I did not misspell the domain name because I was able to install the theme and it worked until I started installing the recommended plugins and pulling in demo content.


#15