Anyone using Magento 2 with EasyEngine?

Hello @virtubox and other friends!

I followed this post and

I didn’t install redis or opacache by the way.

When I type nginx -t, I got the following result.

nginx: [emerg] duplicate location “/” in /var/www/

Any solution?


Honggi An

Hello, make sure your domain configuration in /etc/nginx/sites-availables/yoursite.tld looks like :

server {

    set $MAGE_ROOT /var/www/;

    access_log /var/log/nginx/ rt_cache;
    error_log /var/log/nginx/;

    include /var/www/*.conf;

Dear @virtubox

Thank you very much for your so quick reply, I pass the test nginx -t, but I got the blank installation page, no error log, any idea? When I search the google, I found some post, but I couldn’t find the proper solution yet.


Honggi An

I solved it, it was a permission error!. Thank you very much!

I installed everything with no problem, when I wanted to start adding products there is no store view for me to change and I cant add product configuration because there is no save button, the web setup wizard also does not display.

Everything else in the store displays and works perfectly.

I have attached images. I would really appreciate your help.

Hello @Henry_Martins, try to purge the cache, and to re-compile magento with the CLI :

bin/magento setup:upgrade bin/magento setup:di:compile bin/magento cache:clean

Hi, thanks for the reply. I have tried that many times, doing it inside magento and in the command line. It does not change anything.

Are you in production or developer mode ?

I’m in Developer mode

Guys, magento work in a vps 1/1? Or need more cpu and memory?

It depend on your store size, and on the VPS resources,. But Magento 2 require at least 4GB of RAM,

Thanks for reply.