Amavis throwing error in mail.log


#1

Hello all!

Somehow after installing the mail stack, setting up my mailboxes androundcube and all, I can not receive any emails. This is shown in mail error log:

Sep 21 15:54:01 server amavis[25605]: (25605-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=vimbadmin;host=127.0.0.1;port=3306': Access denied for user 'vimbadmin'@'localhost' (using password: YES) Sep 21 15:54:01 server amavis[25605]: (25605-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 136) line 247. Sep 21 15:54:01 server amavis[25605]: (25605-01) (!)Requesting process rundown after fatal error?

It seems amavis can not access the mail db. But how can I find out about the correct vimbadmin credentials? I didn’t set those up. ee did that…

Would be great if someone could help


#2

Tried to fix it by setting new password for vimbadmin dbuser and replacing the password in amavis config file. However that resulted in a fatal error, when I tried to log in to the vimbadmin interface :22222

So I eventually gave up fixing this, and rebuilt my VPS from scratch, reinstalling ee, its stacks. and now it works.

I guess something got messed up when I removed mailscanner stack and purged it. Then reinstalled it via ee. After that the vimbadmin user was messed up - and apparently all its dependencies.

Only complete reinstall of server fixed it for me.


#3

having the same issue is there any fix without starting again from scratch?