Album gallery count off


#1

Album count in media/album/ is off. Doesn't seem to count default Wall Posts album. Is this expected?

DEBUG INFO PHP 5.3.26 MYSQL 5.5.32 WordPress 3.6.1 BuddyPress 1.8.1 rtMedia 3.2.3 OS Linux Imagick Not Installed GD bundled (2.1.0 compatible) [php.ini] post_max_size 128m [php.ini] upload_max_filesize 128m [php.ini] memory_limit 256M Installed Plugins BuddyPress Group Email Subscription I&T CUSTOM. DO NOT UPDATE by Deryk Wenaus, boonebgorges, r-a-y version 3.4, rtMedia for WordPress, BuddyPress and bbPress by rtCamp version 3.2.3, Error Log Monitor by Janis Elsts version 1.1, Private BuddyPress by Dennis Morhardt version 1.0.4, rtMedia Pro by rtCamp version 1.4 Theme Name BuddyPress Default Theme Version 1.8.1 Author URL http://buddypress.org Template Overrides plugins/buddypress-media/templates/media/album-gallery-item.php, plugins/buddypress-media/templates/media/album-gallery.php, plugins/buddypress-media/templates/media/album-single-edit.php, plugins/buddypress-media/templates/media/media-gallery-item.php, plugins/buddypress-media/templates/media/media-gallery.php, plugins/buddypress-media/templates/media/media-single-edit.php, plugins/buddypress-media/templates/media/media-single.php, plugins/buddypress-media/templates/media/uploader.php Total Albums 4 Total Photos 32

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/4848/2013/10/album-count.png


#2

@jaemaz - The global albums are not included in the count. This is the expected behavior.


#3

I would consider revising or adding it as an option. I understand why that choice was made, but it makes no sense to users. I have several complaining and asking why when they are in the Albums tab, it shows two albums, but the count says 1. It looks like a mistake.


#4

@jaemaz - Yes that actually doesn't make sense. I also feel that It should be the total number of albums that are being displayed on the users profile. I will add this to our todo list and hopefully this should be taken care of in the upcoming releases.


#5

@jaemaz - Update

This has been fixed on the rtMedia GitHub repo and should be available in the next release.


#6