After updating from 1.* to 2.* unable to restart nginx


#1

$ ee --version EasyEngine (ee) version: 2.1.0

~ ⌚ 5:45:50
$ php5-fpm -t
[25-Sep-2014 05:45:58] NOTICE: configuration file /etc/php5/fpm/php-fpm.conf test is successful


~ ⌚ 5:45:58
$ ee stack restart
Executing service nginx restart, please wait...
[ Thu Sep 25 05:46:03 UTC 2014 ] Unable to execute service nginx restart, exit status =  1

$ nginx -t
nginx: [emerg] unknown log format "rt_cache" in /etc/nginx/sites-enabled/22222:7
nginx: configuration file /etc/nginx/nginx.conf test failed



$ cat /var/log/easyengine/update.log

[...] 

Hit http://ppa.launchpad.net trusty/main amd64 Packages
Hit http://ppa.launchpad.net trusty/main i386 Packages
Ign http://ppa.launchpad.net trusty/main Translation-en_US
Ign http://ppa.launchpad.net trusty/main Translation-en
Reading package lists...
stop: Unknown instance:
hostname stop/waiting
themevillage.net
php5-fpm                                        install
‘/usr/share/easyengine/nginx/22222’ -> ‘/etc/nginx/sites-available/22222’
nginx: [emerg] unknown log format "rt_cache" in /etc/nginx/sites-enabled/22222:7
nginx: configuration file /etc/nginx/nginx.conf test failed

I think something might have to do with my hostname ? What did I do wrong there ?


#2

Finally! I think I managed to fix it - I did this:

ee system remove
ee system install

Something just went wrong when updating EasyEngine… phew…


#3

Hello @justnorris,

Glad to know your issue got resolved. EasyEngine 3.1.7 is released (https://github.com/rtCamp/easyengine/releases) with various tweaks and new features. You can upgrade it.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#4