After update i cannot upgrade database


#1

after the 2.21 update i cannot upgrade the database when i click upgrade i get this error

Parse error: syntax error, unexpected T_FUNCTION in /home/..../public_html/wp-content/plugins/buddypress-media/includes/bp-media-upgrade-script.php on line 56

no images show in the users profile now

please help!


#2

Thanks for informing, it seems you are using PHP version less than 5.3. It will be taken care of in our next release within 24 hours.


#3

Hello, first time on here. So first of all, thanks for the excellent plug in!

I too have a problem with updating the database since upgrading from 2.1.5. I have updated to 2.2.2. My server is running PHP5.2. I get a white screen when I try to update the database (with the URL http://mysitename/wp-admin/options-general.php?page=bp-media-settings&bp_media_upgrade_db=1&wp_nonce=bbe4157a61

Do I need to clear the database manually? Can I do any thing from phpmyadmin? I am also running NextGen gallery and BP Courseware. Could these be an issue?

Many thanks in advance,

Mike


#4

@Mike

Roughly, how many files you have uploaded with BuddyPress-media version 2.1.5?

We have just released 2.2.3 which has a better upgrade script. Hopefully, you will not face timeout issues.

If you still run into facing issues, please email to admin@rtcamp.com. We will check out your site and do upgrade for you manually.

The problem is none of site to which we have access is throwing above error. So its hard to debug something without seeing it.


#5

Hi Rahul,

Thanks for your reply. Have sent you an email as requested.

Cheers,
Mike


#6

Hi Mike,

Did not get email yet?

Please send details to admin@rtcamp.com (include wordpress admin/password and ftp-details)?

I will have a look. Most likely its another plugin conflict. Rest assured, if we can “see” the issue, we will find some workaround.


#7