After SSL installation - only shows welcome page on https


#1

Greetings,

after installing ssl certificate, it is showing welcome nginx page on https://

over http:// it is working alright

i am using linode vps on 16.04


#2

Hi @naj33b check following files, which are configured by EE for enabling SSL.

/var/www/example.com/conf/nginx/ssl.conf

listen 443 ssl http2; ssl on; ssl_certificate /etc/letsencrypt/live/serversolace.com/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/serversolace.com/privkey.pem;

and following settings

root@s:~# cat /etc/nginx/conf.d/force-ssl-example.com.conf server { listen 80; server_name www.serversolace.com serversolace.com; return 301 https://serversolace.com$request_uri; }

or just run EE comand to generate those files. ee site update example.com --letsencrypt=on

and make sure following line is present in /etc/nginx/sites-available/example.com

include /var/www/example.com/conf/nginx/*.conf;

If you have not changed any default configurations, this should work. :slight_smile: let me know if this resolves your issue.


#3

Thank you - i am applying and will update


#4

Thank you so much - fixed now


#5

glad to hear that :slight_smile:


#6