After Let's Encrypt SSL, /wp-admin gets redirected to /login


#1

Yesterday I installed a Let’s Encrypt SSL Certificate and got it working (with issues, see other question :))

However, when I try to login to my admin dashboard via url.com/wp-admin I get redirected to a url.com/login page. I tried hardcoding the url with https to wp-config, without success.

Any ideas on what could be the issue?


#2

SSL has nothing to do with renaming wp-login.php. Certainly you have a plugin doing that.

First, deactivate all your plugins:

cd /var/www/domain.com/htdocs
wp plugin deactivate --all

Then reactivate Nginx Helper:

wp plugin activate nginx-helper

Configure your home and blog locations to use HTTPS:

wp option set home https://domain.com
wp option set site_url https://domain.com

Then log in your blog and activate your plugins one by one, until you find which of them is causing you issues.


#3