After adding letsencrypt site ERR_CONNECTION_REFUSED


#1

after following the tutorial here https://easyengine.io/blog/new-release-http2-letsencrypt-support/

my site now is not accessible kindly advice how to fix this asap error showing ERR_CONNECTION_REFUSED


#2

any help here??? your tutorial must have also some troubleshooting when this happens


#3

Hi rnovino,

Could you please provide us the URL to your site, output of the command tail -n 100 /var/log/ee/ee.log , sudo service nginx restart and tail -n 50 /var/www/<yoursite>/logs/error.log?

Waiting for your reply.


#4

here is the results I just change the domain name

2016-05-04 08:01:14,560 (DEBUG) ee : loading template file /usr/lib/ee/templates/siteinfo.mustache 2016-05-04 08:17:33,117 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler 2016-05-04 08:17:33,343 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'edit', 'domainmy.net'] 2016-05-04 08:17:33,343 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7fc7acfb1a20> 2016-05-04 08:17:33,346 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7fc7acfc0240> 2016-05-04 08:17:33,347 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteEditController object at 0x7fc7acfc0518> 2016-05-04 08:17:33,350 (INFO) ee : Initializing EasyEngine Database 2016-05-04 08:30:48,435 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler 2016-05-04 08:30:48,683 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'edit', 'domainmy.net'] 2016-05-04 08:30:48,684 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f728927ea20> 2016-05-04 08:30:48,686 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7f728928c048> 2016-05-04 08:30:48,688 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteEditController object at 0x7f728928c400> 2016-05-04 08:30:48,691 (INFO) ee : Initializing EasyEngine Database 2016-05-04 08:31:43,287 (DEBUG) ee : EEGit: git commit at /etc/nginx 2016-05-04 08:31:43,323 (INFO) ee : Reload : nginx 2016-05-04 08:31:43,362 (DEBUG) ee : nginx: [emerg] the size 10485760 of shared memory zone "SSL" conflicts with already declared size 20971520 in /etc/nginx/sites-enabled/domainmy.net:8 nginx: configuration file /etc/nginx/nginx.conf test failed 2016-05-04 08:31:43,362 (INFO) ee : [Failed] 2016-05-04 08:31:43,362 (ERROR) ee : service nginx reload failed. check issues withnginx -tcommand 2016-05-04 08:32:54,529 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler 2016-05-04 08:32:54,757 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'edit', 'domainmy.net'] 2016-05-04 08:32:54,757 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7fc2d426fa20> 2016-05-04 08:32:54,759 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7fc2d426f828> 2016-05-04 08:32:54,761 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteEditController object at 0x7fc2d427e400> 2016-05-04 08:32:54,764 (INFO) ee : Initializing EasyEngine Database 2016-05-04 08:33:38,775 (DEBUG) ee : EEGit: git commit at /etc/nginx 2016-05-04 08:33:38,801 (INFO) ee : Reload : nginx 2016-05-04 08:33:38,839 (DEBUG) ee : nginx: [emerg] the size 10485760 of shared memory zone "SSL" conflicts with already declared size 20971520 in /etc/nginx/sites-enabled/domainmy.net:8 nginx: configuration file /etc/nginx/nginx.conf test failed 2016-05-04 08:33:38,839 (INFO) ee : [Failed] 2016-05-04 08:33:38,839 (ERROR) ee : service nginx reload failed. check issues withnginx -tcommand 2016-05-04 08:35:07,417 (DEBUG) ee : logging initialized for 'ee' using LoggingLogHandler 2016-05-04 08:35:07,660 (DEBUG) ee : ['/usr/local/bin/ee', 'site', 'edit', 'domainmy.net'] 2016-05-04 08:35:07,660 (DEBUG) ee : collecting arguments/commands for <ee.cli.controllers.base.EEBaseController object at 0x7f90bf8e1a20> 2016-05-04 08:35:07,662 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteController object at 0x7f90bf8e1748> 2016-05-04 08:35:07,664 (DEBUG) ee : collecting arguments/commands for <ee.cli.plugins.site.EESiteEditController object at 0x7f90bf8f02e8> 2016-05-04 08:35:07,667 (INFO) ee : Initializing EasyEngine Database 2016-05-04 08:36:07,455 (DEBUG) ee : EEGit: git commit at /etc/nginx 2016-05-04 08:36:07,482 (INFO) ee : Reload : nginx 2016-05-04 08:36:07,591 (INFO) ee : [OK]

root@localhost:~# tail -n 50 /var/www/domainmy.net/logs/error.log PHP message: PHP 2. include() /var/www/domainmy.net/htdocs/wp-admin/post.ph 2016/05/04 00:06:14 [error] 4629#0: *575002 FastCGI sent in stderr: ": PHP Stack trace: PHP message: PHP 1. {main}() /var/www/domainmy.net/htdocs/wp-admin/post.php:0 PHP message: PHP 2. include() /var/www/domainmy.net/htdocs/wp-admin/post.php:173 PHP message: PHP 3. do_meta_boxes() /var/www/domainmy.net/htdocs/wp-admin/edit-form-advanced.php:693 PHP message: PHP 4. call_user_func:{/var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037}() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP 5. APS_Post_Types::aps_products_metabox() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP Warning: Illegal string offset 'name' in /var/www/domainmy.net/htdocs/wp-content/plugins/aps-products/libs/class-aps-post-types.php on line 363 PHP message: PHP Stack trace: PHP message: PHP 1. {main}() /var/www/domainmy.net/htdocs/wp-admin/post.php:0 PHP message: PHP 2. include() /var/www/domainmy.net/htdocs/wp-admin/post.php:173 PHP message: PHP 3. do_meta_boxes() /var/www/domainmy.net/htdocs/wp-admin/edit-form-advanced.php:693 PHP message: PHP 4. call_user_func:{/var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037}() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP 5. APS_Post_Types::aps_products_metabox() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP Warning: Illegal string offset 'icon' in /var/www/domainmy.net/htdocs/wp-content/plugins/aps-products/libs/class-aps-post-types.php on line 364 PHP message: PHP Stack trace: PHP message: PHP 1. {main}() /var/www/domainmy.net/htdocs/wp-admin/post.php:0 PHP message: PHP 2. include() /var/www/domainmy.net/htdocs/wp-admin/post.php:173 PHP message: PHP 3. do_meta_boxes() /var/www/domainmy.net/htdocs/wp-admin/edit-form-advanced.php:693 PHP message: PHP 4. call_user_func:{/var/www/domainmy.n 2016/05/04 00:06:14 [error] 4629#0: *575002 FastCGI sent in stderr: "ww/domainmy.net/htdocs/wp-admin/post.php:173 PHP message: PHP 3. do_meta_boxes() /var/www/domainmy.net/htdocs/wp-admin/edit-form-advanced.php:693 PHP message: PHP 4. call_user_func:{/var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037}() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP 5. APS_Post_Types::aps_products_metabox() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP Warning: Illegal string offset 'icon' in /var/www/domainmy.net/htdocs/wp-content/plugins/aps-products/libs/class-aps-post-types.php on line 359 PHP message: PHP Stack trace: PHP message: PHP 1. {main}() /var/www/domainmy.net/htdocs/wp-admin/post.php:0 PHP message: PHP 2. include() /var/www/domainmy.net/htdocs/wp-admin/post.php:173 PHP message: PHP 3. do_meta_boxes() /var/www/domainmy.net/htdocs/wp-admin/edit-form-advanced.php:693 PHP message: PHP 4. call_user_func:{/var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037}() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP 5. APS_Post_Types::aps_products_metabox() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP Warning: Illegal string offset 'name' in /var/www/domainmy.net/htdocs/wp-content/plugins/aps-products/libs/class-aps-post-types.php on line 359 PHP message: PHP Stack trace: PHP message: PHP 1. {main}() /var/www/domainmy.net/htdocs/wp-admin/post.php:0 PHP message: PHP 2. include() /var/www/domainmy.net/htdocs/wp-admin/post.php:173 PHP message: PHP 3. do_meta_boxes() /var/www/domainmy.net/htdocs/wp-admin/edit-form-advanced.php:693 PHP message: PHP 4. call_user_func:{/var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037}() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP 5. A 2016/05/04 00:06:14 [error] 4629#0: *575002 FastCGI sent in stderr: "late.php:1037}() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP 5. APS_Post_Types::aps_products_metabox() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP Warning: Illegal string offset 'icon' in /var/www/domainmy.net/htdocs/wp-content/plugins/aps-products/libs/class-aps-post-types.php on line 364 PHP message: PHP Stack trace: PHP message: PHP 1. {main}() /var/www/domainmy.net/htdocs/wp-admin/post.php:0 PHP message: PHP 2. include() /var/www/domainmy.net/htdocs/wp-admin/post.php:173 PHP message: PHP 3. do_meta_boxes() /var/www/domainmy.net/htdocs/wp-admin/edit-form-advanced.php:693 PHP message: PHP 4. call_user_func:{/var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037}() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037 PHP message: PHP 5. APS_Post_Types::aps_products_metabox() /var/www/domainmy.net/htdocs/wp-admin/includes/template.php:1037" while reading upstream, client: 49.149.254.136, server: domainmy.net, request: "GET /wp-admin/post.php?post=42603&action=edit HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "domainmy.net", referrer: "http://domainmy.net/wp-admin/edit.php?post_type=aps-products" 2016/05/04 01:27:46 [error] 4630#0: *537060 FastCGI sent in stderr: "PHP message: PHP Fatal error: Call to undefined function get_header() in /var/www/domainmy.net/htdocs/wp-content/themes/Newsmag/index.php on line 6 PHP message: PHP Stack trace: PHP message: PHP 1. {main}() /var/www/domainmy.net/htdocs/wp-content/themes/Newsmag/index.php:0" while reading response header from upstream, client: 66.249.69.97, server: domainmy.net, request: "GET /wp-content/themes/Newsmag/ HTTP/1.1", upstream: "fastcgi://127.0.0.1:9001", host: "domainmy.net"


#5

how can I manually remove this the letsencypt=off is not working


#6

I have fixed the https now but currently I cant access my wp-admin dashboard it say redirecction loop and also 404


#7

what did you have to do in order to fix it for your site (or were you saying your removed it)?


#8