Admin page loading slow


#1

I’ve noticed the admin page has been loading really slow, checking the error log reveals this:

2016/10/14 18:13:54 [error] 19814#19814: *4108 connect() failed (111: Connection refused) while connecting to upstream, client: IP.IP.IP.IP, server: dylan.duffy.im, request: "GET / HTTP/2.0", upstream: "fastcgi://127.0.0.1:8000", host: "dylan.duffy.im"
2016/10/14 18:14:05 [error] 19814#19814: *4108 connect() failed (111: Connection refused) while connecting to upstream, client: IP.IP.IP.IP, server: dylan.duffy.im, request: "GET /wp-admin/admin.php?page=ithemes-builder-theme HTTP/2.0", upstream: "fastcgi://127.0.0.1:8000", host: "dylan.duffy.im", referrer: "https://dylan.duffy.im/wp-admin/"
2016/10/14 18:15:08 [error] 19814#19814: *4108 connect() failed (111: Connection refused) while connecting to upstream, client: IP.IP.IP.IP, server: dylan.duffy.im, request: "POST /wp-admin/admin-ajax.php HTTP/2.0", upstream: "fastcgi://127.0.0.1:8000", host: "dylan.duffy.im", referrer: "https://dylan.duffy.im/wp-admin/admin.php?page=ithemes-builder-theme"
2016/10/14 18:17:09 [error] 19814#19814: *4108 connect() failed (111: Connection refused) while connecting to upstream, client: IP.IP.IP.IP, server: dylan.duffy.im, request: "POST /wp-admin/admin-ajax.php HTTP/2.0", upstream: "fastcgi://127.0.0.1:8000", host: "dylan.duffy.im", referrer: "https://dylan.duffy.im/wp-admin/admin.php?page=ithemes-builder-theme"
2016/10/14 18:19:10 [error] 19814#19814: *4108 connect() failed (111: Connection refused) while connecting to upstream, client: IP.IP.IP.IP, server: dylan.duffy.im, request: "POST /wp-admin/admin-ajax.php HTTP/2.0", upstream: "fastcgi://127.0.0.1:8000", host: "dylan.duffy.im", referrer: "https://dylan.duffy.im/wp-admin/admin.php?page=ithemes-builder-theme"

The server it’s running on is Debian 8.1 and the site has HHVM enabled. Disabling HHVM seems to make it run just fine and without errors.

Any help is appreciated.


#2

Are you running the wpfc option?

If so… what is your w3tc setup?

Some say enabled database cache slows down backend, for me this was the case.

w3tc should be left alone, with one exception - cdn setup. Utherwise i found it best to leave the settings as is. Also minification is better so setup with “Autoptimize”, “Above The Fold Optimization” and “Google Web Font Optimization”

These all work well together and when properly setup on a good web stack your wp is blazingly fast

Peace =)


#3

Doesn’t use HHVM, php7 will be better and doesn’t cause errors.


#4

HHVM Still outperforms PHP7 in all of my testing and all the tests I’ve found online. Running it with PHP does indeed remove errors, I’d just like to know what causes HHVM to error out.


#5

None of these things are, from my testing, related to the errors I’m encountering and the slow-down as a whole. The front page loads just fine, nice and fast.


#6

With WordPress loading under 500ms with php7, I do not see a reason to use HHVM. If WordPress is almost totally compatible with HHVM, your plugins are maybe not.


#7

I’ve had problems with PHP7, it puts wp in a redirect loop when using social login plugins. I did a rollback to php 5.6 and HHVM, it works just fine. What problems have you experienced with HHVM?


#8

No problems, I just do not see a reason to use it when WordPress is a php CMS fully compatible with php7. For plug-ins, I will not use it plug-in not compatible with php7.


#9