Activity feed uploads not showing up in gallery and vice versa

I’m running latest version of Wordpress & Buddypress & rtMedia.

When users upload an image to the activity feed, I want it to show up in the gallery.

Also, when users use the uploader and upload an image to the gallery page, I want it to post that activity to the Buddypress Activity feed.

How can I do this?

Hey there,

Hope you are doing great! :slight_smile:

Could you please confirm that the setting mentioned below are enabled at your end?

Dashboard >> rtMedia >> Settings >> BuddyPress >> Allow upload from activity stream

If you are not able to upload media from media tab, please also turn on this setting : Enable media in profile

Dashboard >> rtMedia >> Settings >> BuddyPress >> Enable media in profile

You can visit this documentation for more details on rtMedia admin settings :

As per the requirements you have posted, these two options are a must. If any of these is disabled, the feature will not work the way you wish.

Kindly let us know if the issue still persists.



Yes, both settings are set to “on” but when a user uploads an image via activity stream, it Does Not show up in the Gallery.

When a user uploads an image via the image uploader in the Gallery, it Does Not show up on the Activity Stream.

How can I do this?

I’m having the same problem. Any pictures I download to the media doesn’t show up in the activity stream

Any news about this issue ? I got the same problem! The images uploaded in gallery are not shown in activity stream. I have tried to experiment with building up the html from the image url , adding parent div’s one by one. When adding the div class “rtmedia-activity-container” the image disappear’s.

There’s no problems with videos.

Hello @FlemmingH , @tammy1999 and @ngoegan,

We hope you have confirmed the issue by activating WordPress default theme and deactivating other plugins.

Please once try these suggestions from the other related thread here - Media upload in Buddypree activity stream

Thank you.

Yes i have tried deactivating alll plugins and default themes. The only thing working is when i deactivate rtMedia!?

Hello @FlemmingH,

Have you tried the solutions suggested in the above mention thread?

Also, please check if there are any server errors under error-log or any javascript error in the browser console.