Accessing phpmyadmin


#1

Hi there,

Have installed phpmyadmin successfully – when trying to access I am used for a username/password. Have tried all passowrd that was set during installation including the default combination as suggested here: https://github.com/EasyEngine/easyengine/wiki/FAQ#how-to-access-phpmyadmin-installed-with-easyengine but still no luck.

I am repeatedly asked for a password no matter what password is entered – finally after giving up a 401 error…

Could someone possibly assist?

Kind regards franwess


#2

Did you get to the phpMyAdmin login or are you stuck at this screen:

Also, is WordPress already installed and working?


#3

@bamajr: Yes, stuck on that screen and WordPress is already running on the site.

Thank you! franwess


#4

@harshadyeola: Would it be possible for you to assist with this issue?

Kind regards franwess


#5

The “Name” and “Password” being asked for in this HTTP Auth Dialogue, is the one provided when you originally ran:

ee stack install

…with --all, --web, --admin, --utils (or possibly some others). You may have noticed the lines that said:

HTTP Auth User Name: easyengine HTTP Auth Password: ???

…as shown below:

If you don’t remember what the User Name and/or Password are, you can simply run:

ee secure --auth

…and set a new User Name and Password.


#6

@bamajr thanks for that – worked perfectly :smile: Regards franwess


#7

I was having the same issue, I changed username/password still getting a 404 error then I Installed admin tools and got the following output

sudo ee stack install --admin

NGINX Stable already installed
PHP already installed
MySQL connection is already alive
Downloading phpMyAdmin           [Done]
Downloading Adminer              [Done]
Downloading phpMemcachedAdmin    [Done]
Downloading clean.php            [Done]
Downloading opcache.php          [Done]
Downloading Opgui                [Done]
Downloading OCP.php              [Done]
Downloading Webgrind             [Done]
Downloading pt-query-advisor     [Done]
Downloading Anemometer           [Done]
Successfully installed packages

Now i can log into phpmyadmin but get the following error:

phpMyAdmin - ErrorThe mbstring extension is missing. Please check your PHP configuration.

Thanks in advanced!


#8

** FIXED ** I ran this code and it installed the needed mbstring i was missing.

apt-get install php5.6-mbstring php5.6-bcmath php5.6-xml