502 Bad Gateway in fresh installation


#1

Hello, Could you help me ! I got 502 Bad Gateway when I try to access my new wordpress wpfc website the domain name is testa.net and it resolve fine to myserver IP via hosts in widnows10

here is : tail -n 50 /var/log/nginx/testa.net.error.log

2016/07/12 16:01:27 [error] 333#333: *1 connect() failed (111: Connection refused) while connecting to upstream, client: 172.94.93.29, server: testa.net, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "testa.net"

I tried ti fix by :-

root@newbest:~# netstat -an | grep 9000 root@newbest:~# it gave no thing

I would like to make sure that php running well

root@newbest:~# ee stack status PHP7.0-FPM is not installed HHVM is not installed ‘ascii’ codec can’t decode byte 0xe2 in position 0: ordinal not in range(128) root@newbest:~# I tried also to fix ‘ascii’ codec by : sudo locale-gen “en_US.UTF-8”

then reboot NO thing too

and am still facing 502 Bad Gateway Error and ee stack status

I tried to check PHP5.6-fpm log here is it :-

[12-Jul-2016 15:50:59] NOTICE: fpm is running, pid 288 [12-Jul-2016 15:50:59] NOTICE: ready to handle connections [12-Jul-2016 15:50:59] NOTICE: systemd monitor interval set to 10000ms [12-Jul-2016 15:59:15] NOTICE: Terminating … [12-Jul-2016 15:59:15] NOTICE: exiting, bye-bye! [12-Jul-2016 15:59:27] NOTICE: fpm is running, pid 283 [12-Jul-2016 15:59:27] NOTICE: ready to handle connections [12-Jul-2016 15:59:27] NOTICE: systemd monitor interval set to 10000ms [12-Jul-2016 19:01:49] NOTICE: Terminating … [12-Jul-2016 19:01:49] NOTICE: exiting, bye-bye! [12-Jul-2016 19:01:49] NOTICE: fpm is running, pid 1051 [12-Jul-2016 19:01:49] NOTICE: ready to handle connections [12-Jul-2016 19:01:49] NOTICE: systemd monitor interval set to 10000ms

it look running fine :

root@newbest:/var/log# service php5.6-fpm status ق php5.6-fpm.service - The PHP 5.6 FastCGI Process Manager Loaded: loaded (/lib/systemd/system/php5.6-fpm.service; enabled; vendor prese Active: active (running) since Tue 2016-07-12 19:01:49 EDT; 5min ago Docs: man:php-fpm5.6(8) Main PID: 1051 (php-fpm5.6) Status: "Processes active: 0, idle: 2, Requests: 0, slow: 0, Traffic: 0req/se CGroup: /system.slice/php5.6-fpm.service

Here is my software: Ubuntu 16.04 LTS (GNU/Linux 2.6.32-042stab116.1 x86_64) EasyEngine v3.7.1

Regards,


#2

Hello, althoght am new in EE I fix this issue after too much attempts and too much time

The problem was in LANGUAGE .

I fix it:

export LANGUAGE=“en_US.UTF-8” echo ‘LANGUAGE=“en_US.UTF-8”’ >> /etc/default/locale echo ‘LC_ALL=“en_US.UTF-8”’ >> /etc/default/locale


#3