502 "Bad Gateway" Error after server reboot


I successfully installed EE4.06 and set up a couple of WordPress sites. Everything was working well with cache, Lets Encrypt and -local-redis option. Then I rebooted the server (Ubuntu 18.04). Now for both sites, I get 502 Bad Gateway error.

Any ideas on what could be wrong?



1 Like

Might be related to these:



I’ve had to do at least two reboots to get EE’s services to start properly.

Thanks for the info. If I disable and then enable the site (ee site disable, ee site enable) the 502 error goes away. However, after reboot, I get the 502 error again.

I have the same problem.

Any of you get the problem solved?

After disable and enable the site, I get “Error establishing a database connection” message.


1 Like

Try ee service enable db --force and see if the error still persists

1 Like

It worked. Thank you.

When I try this command I get " unknown --force parameter" error message.

1 Like

Me too, no answers. :frowning:

Try without the --force parameter.

Now the same error is back.
This time, nothing seems to work.
Anyone else?

upgraded my ubuntu 1804 to latest today and i believe updated docker packages. And now when i restart server i got bad gateway 502 error like others said. ee site disable, and enable works for now. But its annoying, how can we prevent this?

Now one site get 502 Bad Gateway.

ee site disable/enable don’t work anymore.

Please tell me, how to study about wordpress from beginning to end.