502 "Bad Gateway" Error after server reboot


#1

Hi

I successfully installed EE4.06 and set up a couple of WordPress sites. Everything was working well with cache, Lets Encrypt and -local-redis option. Then I rebooted the server (Ubuntu 18.04). Now for both sites, I get 502 Bad Gateway error.

Any ideas on what could be wrong?

Thanks

Robert


#2

Might be related to these:

https://community.easyengine.io/t/easyengine-services-not-running-on-server-reboot/11651/3

https://github.com/EasyEngine/easyengine/issues/1251

I’ve had to do at least two reboots to get EE’s services to start properly.


#3

Thanks for the info. If I disable and then enable the site (ee site disable, ee site enable) the 502 error goes away. However, after reboot, I get the 502 error again.


#4

I have the same problem.

Any of you get the problem solved?

After disable and enable the site, I get “Error establishing a database connection” message.

Thanks.


#5

Try ee service enable db --force and see if the error still persists


#6

It worked. Thank you.


#7

When I try this command I get " unknown --force parameter" error message.


#8

Me too, no answers. :frowning:


#9

Try without the --force parameter.


#10

Now the same error is back.
This time, nothing seems to work.
Anyone else?


#11

upgraded my ubuntu 1804 to latest today and i believe updated docker packages. And now when i restart server i got bad gateway 502 error like others said. ee site disable, and enable works for now. But its annoying, how can we prevent this?


#12

Now one site get 502 Bad Gateway.

ee site disable/enable don’t work anymore.


#13

Please tell me, how to study about wordpress from beginning to end.