404 page not found


#1

Hi to all. I use the plugin rtmedia but I get the 404 page. I tried to change the permalink settings but it didn't work. How can I fix the problem?


#2

@apalumbo - Could you check if it works by switching to a default theme ( Like BuddyPress Default Theme, Twenty Thirteen, Twenty Twelve ) and by deactivating all the other plugins ( except BuddyPress and rtMedia )

Also it would be great if you could share the debug info available under the rtMedia Support Tab in the Dashboard. Check this link for more info on how to get fast and quality support -> http://rtcamp.com/rtmedia/support/


#3

Thank you @joshuaabenazer - In my Wordpress test I did what you wrote and it works. On the site that I’m realizing I totally changed the default theme for BuddyPress and if I go directly to the page of the media, I am redirected to page.php of Wordpress theme, I should view the page rt media. I don’t have redirects in header.php. I am using WordPress 1.7.1 and BuddyPress 1.7.2. Do you think I need to update BuddyPress? Here is the link http://dogzonenyc.com/members/developing_it/media


#4

@apalumbo - It is always advisable to keep your plugins, themes and WordPress installation up to date. Try updating and check if it resolves your issue.


#5

I solved with a trick. I used the rtmedia_load_template() in page.php and now it works. It’s important to use function wp_footer() in footer.php


#6

@apalumbo - Glad to know you could get it working. :slight_smile:


#7

this was a private reply with post_id 51889


#8

Unfortunately I do not know much about coding :slight_smile:


#9

@apalumbo - Could you give some insight to @bertina on how exactly did you resolve this issue.


#10

@bertina if you go to page media of the plugin, are you in 404 or in page.php? If you are in page.php but you don’t see rtmedia template, write rtmedia_load_template() in point of page.php where you should see rtmedia template. wp_footer() is important because this function print javascript variables used by rtmedia.


#11

@apalumbo - Thanks for the detail. Also wp_footer() is a major function and should not be ignored in any case, as it could break a lot of other plugins.

@bertina - Also first try re-saving your permalinks. Maybe that could also resolve your issue.


#12

Thank you very much
My problem was solved
Finding the ID of widgets and placing it in the plugin settings
@apalumbo - Of course, your tips helped me so much

Now my problem is that when scrolling, the Fixed widget below go under another widget
my URL/Site: mpress.ir


#13

@bertina - Sorry to say that would be a theme issue. You would need to contact your theme developer regarding that.


#14

#15