2.1 Mail Setup "No such file or directory" ViMbAdmin Setup


#1

I’m trying to install the mail server in 2.1 released today but I’m getting stuck at after I get the configure VimBadmin address and security salt.

I copy the address exact and paste in terminal but I get “No such file or directory” and can’t get passed. I’ve tried dropping the ‘s’ on the https but no luck.

I don’t have an SSL cert on my site, is that the issue?


#2

@magichew, Hello, Did you followed https://github.com/rtCamp/easyengine/wiki/Install-Mail-Packages this tutorial?

Also did you got following message?

Configure ViMbAdmin:    https://example.com:22222/vimbadmin    
Security Salt:     UpRBT4LLJwfFcZTNOg0CJkDeJSnSLPYsUylCFzrILcoAreOPRhVwqqipjTCltOBw

Successfully installed mail server packages

#3

Yes. Those are the instruction that I have followed.

Just ran “ee stack install mail” again and got this…

Found installed Dovecot Packages server, exit status= 1


#4

Whoops. My issue is different now. I have realised my mistake. I wasn’t following the instructions correctly! I was trying to do this in terminal.

Now I’ve realised this must be put into the browser I have don’t so but I’ve been prompted for a username and password. No where to paste security salt.


#5

@magichew, You need to paste the security salt on ViMbAdmin on browser at address https://example.com:22222/vimbadmin during the first time only. This is only to complete ViMbAdmin setup.

If you lost your security salt you can get that in EasyEngine log file: just try:

grep -Hr "Security Salt:" /var/log/easyengine/*

#6

I’ve never had the chance to enter the salt. I am confronted with a username and password box to which I do not know what to type.


#7

@magichew, During testing we never faced this issue. Can you send us output of following command?

cat /var/log/easyengine/*

You can send that in Private Message


#8

Okay. Not sure how to send a private message to you. I’ve clicked on your profile but can’t seem to find an option. I’ll keep looking.


#9

Tremendous! I’m at the point where I can add my salt. Thank you very much for your help.


#10

I am glad your issue is solved :smile:


#11