Timeout executing a export plugin in WordPress. How to disable timeouts (or extend time) on EEv4?

Hi, I’ve got a WordPress blog installed through EasyEngine v4 and I’m experimenting with other VPS and the Ghost CMS. There’s a new version and a plugin to migrate content from a WP blog to the Ghost one.

I’ve installed the plugin, but when I try to run it the page keeps loading for a few seconds and then stops and shows an error message saying that "The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.”

According to WordPress support messages this must be due to some kind of memory limitation or maybe a timeout issue. I’ve modified several parameters in the custom.ini file on my nginx config folder

max_input_vars = 1234
max_memory_limit = 1024M
max_execution_time = 2000
upload_max_filesize =100M
post_max_size =100M

But I’ve found that the memory limit does not refers to that, and to change the one that is valid for (at least) this plugin is

/opt/easyengine/sites/mysite.com/app/htdocs/wp-includes/default-constants.php

It is there when I can setup a different value to the ‘WP_MAX_MEMORY_LIMIT’) value.

Even doing this the script fails and it stops trying to do whatever it does after 30 seconds aprox (sometimes a little less). I’ve tried to change the ‘keepalive_timeout 30’ parameter on the nginx.conf file, but it doesn’t seem to work either. The message appears whatever I do.

Is there someway to try to fix this and make the script run? You can find the discussion with the plugin developer at the Ghost support forum, here.

Thanks