SSL Renew Problem


Hi Guys Im having major SSL problems

This is an error message received in response to this command.

ee site ssl

Starting SSL verification.
Warning: Failed to verify SSL: cURL error 60: SSL certificate problem: certificate has expired (see
Warning: Check logs and retry ee site ssl once the issue is resolved.

Im also continually getting this
Error: Site already contains SSL.

Any guidance appreciated …causing downtime.


have the same issue too. latest v4 version, certificate has expired and can’t figure out a way to renew it

any help would be appreciated


Try this and see if it gives you the same error.

ee site ssl-renew --all


it does, i’ve tried every command suggested here

ee site ssl-renew site
ee site ssl-renew --all

ee site update . com --le=off
Error: Site . com already contains SSL.

./letsencrypt-auto certonly --webroot -w /opt/easyengine/sites/ -d site . com -d . com --email --text --agree-tos runs into acme well-known issue

and so on.

as time is of an essence here, i’ll PP $100 to the person that provides working solution to this issue.


Tried adding --force ?

Not sure if this is the cause but just incase, have you also added a CAA dns record?


yep tried --force. dns is sound

thanks for suggestion. currently i’m backing up WP, deleting site and re-creating it…


Sorry to hear and hope you get sorted.
I have a few issues myself with non-intentional redirection and SSL not renewing itself so probably gonna abandon ship to runcloud and see what the fuss is about while the issues get sorted out in ee4.


did the same, moved important sites to sendgrid and for less important re-created under ee


Same here:

Starting SSL verification.
PHP Fatal error:  Uncaught GuzzleHttp\Exception\RequestException: cURL error 60: SSL certificate problem: certificate has expired (see in phar:///usr/local/bin/ee/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:186
Stack trace:
#0 phar:///usr/local/bin/ee/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(149): GuzzleHttp\Handler\CurlFactory::createRejection(Object(GuzzleHttp\Handler\EasyHandle), Array)
#1 phar:///usr/local/bin/ee/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(102): GuzzleHttp\Handler\CurlFactory::finishError(Object(GuzzleHttp\Handler\CurlHandler), Object(GuzzleHttp\Handler\EasyHandle), Object(GuzzleHttp\Handler\CurlFactory))
#2 phar:///usr/local/bin/ee/vendor/guzzlehttp/guzzle/src/Handler/CurlHandler.php(43): GuzzleHttp\Handler\CurlFactory::finish(Object(GuzzleHttp\Handler\CurlHandler), Object(GuzzleHttp\Handler\EasyHandle), Object(GuzzleHttp\Handler\CurlFactory))
#3 phar:///usr/local/bin/ee/vendor/guzzlehttp/guzzle/src/Handler/Proxy.php(28): Guz in phar:///usr/local/bin/ee/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 186
Warning: An Error occurred. Initiating clean-up.
Warning: Exiting gracefully after rolling back. This may take some time.
Success: Rollback complete. Exiting now.

On sudo ee site ssl-renew
Version: EE v4.0.14
Unfortunately, I am quite disappointed with the EE v4. It’s quite slow (maybe due to the docker containers, which should be no problem), tutorials and commands are outdated (but still on the website), dockers run as root, elementary commands do not work reliably. Is there any reliable alternative to easyengine?


I would like some feedback on my script:


Hi Guys,

I found the solution to this problem in this thread.

Hope it helps you also.