[Solved] ‘ZipArchive’ not found when trying to enable ee-admin


#1

i can access domain.com/ee-admin but i don’t remember adding any password when i enable it

============== EDIT ================

Reenable ee admin and got the following error:


#2

@efyandro Please check the documentation https://easyengine.io/handbook/admin-tools


#3

login was successful but only find this:

Oops! That page can’t be found.


#4

How did you install EasyEngine? Did you use this: wget -qO ee rt.cx/ee4 && sudo bash ee as that installation takes care of all the required php extensions.

PHP zip extension is missing in your case. Ideally, if you used the EasyEngine installer, then please share your system info as well as install logs:

ee cli info | curl -F "sprunge=<${1:--}" http://sprunge.us

# Installation logs
cat /opt/easyengine/logs/install.log | curl -F "sprunge=<${1:--}" http://sprunge.us

You can search on how to install zip extension and install it your php-cli and then re-install admin-tools, that should fix this issue, or you can re-run the standard installer script: wget -qO ee rt.cx/ee4 && sudo bash ee and let it fix missing dependencies.


#5

here’s the answer

root@vapps:~# ee cli info | curl -F “sprunge=<${1:–}” http://sprunge.us
http://sprunge.us/s48T5R
root@vapps:~# cat /opt/easyengine/logs/install.log | curl -F “sprunge=<${1:–}” http://sprunge.us
http://sprunge.us/SeOO81

will it messed up my site if i re-run installer script??
and if i want to install zip extension do i install docker extension or standar zip.co php module?

============= EDIT ===============
similar issue: Enable admin-tools error

============= EDIT ===============
i re-run easyengine standar installer script and got the following error:

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists…
Building dependency tree…
Reading state information…
0 upgraded, 0 newly installed, 0 to remove and 110 not upgraded.
-----> zip not installed. Installing…

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists…
Building dependency tree…
Reading state information…
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php7.2-zip : Depends: libzip4 (>= 1.0) but it is not installable
E: Unable to correct problems, you have held broken packages.


#6

As the error suggests, you do not have libzip4 apt package.
Run the following commands:

apt install libzip4 -y
apt install php7.2-zip -y

Then re-enable admin-tools.


#7

well i found the fix for this issue. apparently ubuntu 18.04 doesn’t include universe to its repo

sudo add-apt-repository universe
sudo apt update

then you can install php7.2-zip just fine

thankyou for your assistance @mrrobot47 @mriyam.tamuli