One touch, complete, offsite, set-it-and-forget-it backup solution


#21

i am tryng to run it manually


#22

Have you fully re-installed raptor with:

git clone https://github.com/openspace42/raptor

bash raptor/setup

?

Please post previously ran commands and output received. Thanks


#23

Install raptor for local backupds on ubuntu 16.04 and get this:


#24

Sorry guys @diamond_sharma @Alexei_Yakovenko , forgot to update the README, the path is now:

openspace42/raptor/tools/raptor-backup

to comply with the new bash-framework we’ve been working on.

The manual backup command is therefore:

bash openspace42/raptor/tools/raptor-backup


#25

Let me know if everything’s working for you, the code has been completely re-written and it’s important to get things right for everyone


#26

Now:

-bash: openspace42/raptor/tools/raptor-backup: Permission denied


#27

@Alexei_Yakovenko are you running:

bash openspace42/raptor/tools/raptor-backup

or just

openspace42/raptor/tools/raptor-backup

?


#28

Now works well, thank you!


#29

Ok great


#30

Works for Single sites !

What about Multi-sites, is this WP Multisites Friendly hosted with EE ?


#31

ignore this post. i found the answer by googling “duplicity easyengine” for this answer.

Thanks for posting this. I have ubuntu 16.04 on AWS [amazon] with easy engine multi site installed and I have watched both of your installation videos on youtube, and I just tried to install but got an error message.

After running bash raptor/setup I get:

Finished installing dependencies.

/root/openspace42/bash-functions/functions/install_duplicity: line 18: pip: command not found

when I try to run the next command i get:

root@ip-my-site:~# bash openspace42/raptor/tools/raptor-backup

bash: openspace42/raptor/tools/raptor-backup: No such file or directory

root@ip-my-site:~#

root@ip-my-site:~# dir

openspace42 raptor

root@ip-my-site:~# cd openspace42

root@ip-my-site:~/openspace42# dir

bash-functions raptor

root@ip-my-site:~/openspace42# cd raptor

root@ip-my-site:~/openspace42/raptor# dir

conf

root@ip-my-site:~/openspace42/raptor# cd conf

root@ip-my-site:~/openspace42/raptor/conf# dir

version

root@ip-my-site:~/openspace42/raptor/conf#

I ran the script below again and got: root@ip-my-site:~# bash openspace42/raptor/tools/raptor-backup

Starting raptor-backup script on 2018-06-03_20-16-13…

chmod: cannot access ‘/root/logs/raptor-backup’: No such file or directory

I have no idea what I’m doing wrong as I just followed the instructions on the git page. Any help or suggestions offered would be greatly appreciated.

Thanks in advance


#32

There’s currently no support for MS, I’ll try to add this in the future.


#33

I’m glad that fixed it. Is everything working now?

I would kindly ask you to share your distro name and version anyway in order to debug. We install duplicity as so:

os-install_dependencies -p duplicity python-pip pwgen pv ufw pwgen curl
pip install --upgrade pip
pip install --upgrade boto

It would be interesting to know where things went wrong for you.

Thanks!


#34

Thanks for the quick reply! I wish I could say that it worked for me but it didn’t. I had to install pwgen because when i tried to set up the s3 backup i got my 2nd error: /root/openspace42/bash-functions/functions/setup_backup_restore: line 89: pwgen: command not found

Installing pwgen fixed that but now i have two more issues:

Issue one: I get a blank s3 passphrase when i Try to set up s3 backups.

view picture of passphrase error message

Issue two: I have changed my mysql database from local to an AWS RDS so when I tried to do a local backup I got the following error that I don’t know how to fix:

mysqldump: Got error: 1045: “Access denied for user ‘store_G9g5Tfpabc’@‘my-ip-addresss’ (using password: YES)” when trying to connect

Once again, any help you can offer with fixing this issue would be greatly appreciated.

I am using Ubuntu 16.04.4 LTS

Thanks for taking the time to update this script and help me.


#35

Ok I see. Let’s leave the Mysql issue aside for now as that involves extra developement, but we’ll look into that once the installation issue is solved.

We need to figure out why the dependency installation isn’t working.

Could you please start clean and rm -r openspace42/raptor, re-clone, reinstall in bleeding_edge mode as so: bash raptor/setup -be, and post the entire output here? I’ve made some changes as to how dependency installations are performed as to make the errors more verbose.

Thanks


#36

Hi, I just tried installing Raptor but had a problem:

Unpacking duplicity (0.7.17-0ubuntu0ppa1353~ubuntu16.04.1) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up librsync1:amd64 (0.9.7-10) ...
Setting up python-monotonic (0.6-2) ...
Setting up python-six (1.10.0-3) ...
Setting up python-fasteners (0.12.0-2ubuntu1) ...
Setting up python-ptyprocess (0.5-1) ...
Setting up python-pexpect (4.0.1-1) ...
Setting up duplicity (0.7.17-0ubuntu0ppa1353~ubuntu16.04.1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...

Finished installing dependencies.

/root/openspace42/bash-functions/functions/install_duplicity: line 18: pip: command not found

And it ends there. Any ideas? Thanks!


#37

While installing Raptor, why does it ask about whether or not to install the full easy engine stack and phpMyAdmin? Isn’t the full stack already installed if I have easy engine installed?

Thanks


#39

@sshanky hi there. give me a minute to check please.


#40

@chi_soul @sshanky I’ve figured this out. It was a stupid escaping error. The command was only installing duplicity instead of all the dependencies [duplicity python-pip pwgen pv ufw pwgen curl] because the argument wasn’t quoted and therefore only duplicity was being passed to the command.

I missed it until now because I’m always beta testing on my own systems that already have everything installed, that’s why we need you guys who are new to the project so that we have real actual data about fresh new installs like yours.

First off remove the raptor folder with rm -r openspace42/raptor and then try again with bash raptor/setup -be and let me know if this works out for you.

You will have to run the setup again but this way we’ll know you won’t have any more issues.

Thanks!


#41

Not in my experience, no, I’ve always had to install some modules on my own, especially PMA, which was never installed by default and especially its dependency composer always needed to be installed manually. This might be fixed in EE v4 but for now we need this command to be on the safe side.