HTTP/2 Push Nginx module not installed?


#21

@portofacil

On the FREE plane as well.

But it did not work for me.


#22

@robsonwp I don’t want to update nginx now on production. Not worth my time at this point (using CDN for almost everything anyway)

But: Have you tried @virtubox nginx update script? What is your nginx openssl version? (use Nginx -V, with capital “v”)


#23

@treelicker nginx version: nginx/1.14.0 (EasyEngine) OpenSSL 1.0.1k 8 Jan 2015 (running with OpenSSL 1.0.1t 3 May 2016) TLS SNI support enabled

I have already updated the NGINX.

I want to enable HTTP / 2 Server Push in WordPress.

But it’s not working. :disappointed_relieved:


#24

So, according to Nginx docu, you need Nginx OpenSSL from 1.0.2 and we both have lower than that

That’s why I said you can try virtubox script. He says it can update the nginx software including openssl. Do you want to give it a try?


#25

@treelicker Now it’s clear :grinning:.

Do you have a tutorial that teaches you how to update NGINX through Virtualbox?

But can I upgrade by overlaying the Easyengine installation or do I need to uninstall something?


#26

It’s not virtualbox, it’s the user @virtubox who posted his/her script here in this thread, just look at the messages above

I don’t know, you can ask him/her


#27

Ok. Thank you.


#28

@virtubox I updated NGINX using your bash script, but not yet enabled HTTP / 2 Push.

Anything else I should do?


#29

Hello,

yes, you have to add the directive http2_push with the path of the files you want to push. For example, if you want to push jquery.min.js, you have edit your vhost and to add the exact path of the file jquery.min.js, :

location / {
  try_files $uri $uri/ /index.php?$args;
  http2_push /js/jquery.min.js;
}

This is only an example, but you have to add a line http2_push for each file you want to push.


#31

Finally tried @virtubox script and it worked well (except - maybe - not taking into account backports)

Thanks

Is there a PHP upgrader as well?